summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 704a896b2..17ed79583 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -313,6 +313,21 @@ my %optional_features = (
}
}
},
+ elasticsearch => {
+ description => 'Elasticsearch-powered searches',
+ prereqs => {
+ runtime => {
+ recommends => {
+ 'Term::ProgressBar' => 0,
+ },
+ requires => {
+ 'Search::Elasticsearch' => 0,
+ 'IO::Async' => 0,
+ 'Role::Tiny' => 0,
+ },
+ }
+ },
+ },
);
for my $file ( glob("extensions/*/Config.pm") ) {