summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3af1d58e5..cbe3c8a46 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -87,8 +87,11 @@ my %all_features = (
# Windows requires some additional modules.
if ( $^O eq 'MSWin32' ) {
- $requires{'Win32'} = '0.35';
- $requires{'Win32::API'} = '0.55';
+ # 0.45 implements the GetConsoleOutputCP() method.
+ # It also supports Windows 7. Set this to 0.52 to support Windows 10.
+ $requires{'Win32'} = '0.45';
+ # 0.63 fixes a problem with Strawberry Perl 5.14.1.
+ $requires{'Win32::API'} = '0.63';
$requires{'DateTime::TimeZone::Local::Win32'} = '1.64';
}