summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDave Reisner <d@falconindy.com>2011-06-12 04:33:32 +0200
committerThomas Bächler <thomas@archlinux.org>2011-06-25 12:25:45 +0200
commit8ca2543c17819e754d2ebf467acfc65a636d25f2 (patch)
treed7e02593c3d4f4607d3214b2be5079c5c836c5cd /PKGBUILD
parentbb2b9737a8343a1a3bb87a15ffb605ce8ff2af70 (diff)
downloadmkinitcpio-8ca2543c17819e754d2ebf467acfc65a636d25f2.tar.gz
mkinitcpio-8ca2543c17819e754d2ebf467acfc65a636d25f2.tar.xz
add a PKGBUILD for easier testing from the repo
Inspired by the PKGBUILD included with the initscripts repo Signed-off-by: Dave Reisner <d@falconindy.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..58716c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=mkinitcpio-git
+IFS='-' read pkgver pkgrel _ < <(git describe)
+pkgdesc="Modular initramfs image creation utility"
+arch=(any)
+url="http://www.archlinux.org/"
+license=('GPL')
+conflicts=('mkinitcpio')
+provides=('mkinitcpio=9999')
+depends=('mkinitcpio-busybox>=1.16.1-2' 'module-init-tools' 'util-linux>=2.19' 'libarchive' 'coreutils'
+ 'bash' 'findutils' 'sed' 'grep' 'filesystem>=2009.01-2' 'udev>=168' 'file' 'gzip')
+optdepends=('xz: Use lzma or xz compression for the initramfs image'
+ 'bzip2: Use bzip2 compression for the initramfs image'
+ 'lzop: Use lzo compression for the initramfs image'
+ 'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
+replaces=('mkinitrd' 'mkinitramfs' 'klibc' 'klibc-extras' 'klibc-kbd'
+ 'klibc-module-init-tools' 'klibc-udev')
+backup=(etc/mkinitcpio.conf)
+
+build() {
+ make -C ..
+}
+
+package() {
+ make -C .. DESTDIR="$pkgdir" install
+}