summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2019-08-16 01:55:45 +0200
committerAllan McRae <allan@archlinux.org>2019-10-04 03:25:48 +0200
commitbcb44891ef8aa6feee3090cc0fd87b60e73aed5d (patch)
tree0de0ec9b8c08ccc969293f6f6114e487e1565769 /Makefile.am
parent024fde9748692c71f0d9e6c667439c912a78b6df (diff)
downloadpacman-bcb44891ef8aa6feee3090cc0fd87b60e73aed5d.tar.gz
pacman-bcb44891ef8aa6feee3090cc0fd87b60e73aed5d.tar.xz
autotools: distribute meson files
If we use make dist to create the official, signed release tarballs, those will not have meson build files by default since autotools doesn't know what they are. Also distribute all src/common/ files. We never strictly needed any of them to be distributed with autotools, because the dist tarball dereferences the symlinks (???), but only some of them were being distributed, and meson needs them to be in the right location as we only build libcommon from the primary files. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 98ad8b62..c661f447 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,14 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-doc --disable-git-version \
# Some files automatically included, so they aren't specified below:
# AUTHORS, COPYING, NEWS, README
-EXTRA_DIST = HACKING test/tap.sh
+EXTRA_DIST = \
+ HACKING test/tap.sh \
+ meson.build meson_options.txt \
+ build-aux/edit-script.sh.in \
+ build-aux/meson-install-script.sh \
+ build-aux/meson-make-symlink.sh \
+ build-aux/script-wrapper.sh.in
+
# Sample makepkg prototype files
pkgdatadir = ${datadir}/${PACKAGE}