summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2014-09-29 00:06:30 +0200
committerAndrew Gregory <andrew.gregory.8@gmail.com>2017-05-11 06:45:30 +0200
commit1a2770afa84537b6f06d286f600172da8c31ea1f (patch)
treec314a0218c4ee4458d1733eee8d36956f0859df5 /configure.ac
parentdb7f5b98fb97c2cd63ef0c092777e46bfc2bd211 (diff)
downloadpacman-1a2770afa84537b6f06d286f600172da8c31ea1f.tar.gz
pacman-1a2770afa84537b6f06d286f600172da8c31ea1f.tar.xz
wip: updated build tools for multithread
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 57f068d3..1fcfc5b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -260,14 +260,14 @@ AS_IF([test "x$with_gpgme" != "xno"],
have_gpgme=no
AS_IF([test "x$with_gpgme" != "xno"],
- [AM_PATH_GPGME([1.3.0],
+ [AM_PATH_GPGME_PTHREAD([1.3.0],
[LIBS_save="$LIBS"
CPPFLAGS_save="$CPPFLAGS"
CFLAGS_save="$CFLAGS"
- LIBS="$LIBS $GPGME_LIBS"
- CPPFLAGS="$CPPFLAGS $GPGME_CPPFLAGS"
- CFLAGS="$CFLAGS $GPGME_CFLAGS"
+ LIBS="$LIBS $GPGME_PTHREAD_LIBS"
+ CPPFLAGS="$CPPFLAGS $GPGME_PTHREAD_CPPFLAGS"
+ CFLAGS="$CFLAGS $GPGME_PTHREAD_CFLAGS"
AC_MSG_CHECKING([for sane gpgme])
AC_LINK_IFELSE(
@@ -279,8 +279,8 @@ AS_IF([test "x$with_gpgme" != "xno"],
AC_DEFINE([HAVE_LIBGPGME], [1], [Define if gpgme should be used to provide GPG signature support.])],
[AC_MSG_RESULT([no])
have_gpgme=no
- unset GPGME_LIBS
- unset GPGME_CFLAGS]
+ unset GPGME_PTHREAD_LIBS
+ unset GPGME_PTHREAD_CFLAGS]
AS_IF([test "x$with_gpgme" = "xyes"],
[AC_MSG_FAILURE([*** gpgme >= 1.3.0 is needed for GPG signature support])])
)