summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAurelien Foret <aurelien@archlinux.org>2006-02-17 21:48:45 +0100
committerAurelien Foret <aurelien@archlinux.org>2006-02-17 21:48:45 +0100
commit48cc9f3beb7053f51fcdabe25439faae648b6370 (patch)
tree028da3c227ca90bf6b60d41cb016b10812312357 /configure.ac
parent4aff153d7b3cb9e0d2ba698a11120d13c5903ff1 (diff)
downloadpacman-48cc9f3beb7053f51fcdabe25439faae648b6370.tar.gz
pacman-48cc9f3beb7053f51fcdabe25439faae648b6370.tar.xz
doxygen support for autotools (patch from Christian Hamar <krics@linuxforum.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d6f8d51..43f05519 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,11 @@ AC_ARG_ENABLE(fakeroot,
AC_HELP_STRING([--disable-fakeoot], [Disable fakeroot proof support]),
[fakeroot=$enableval], [fakeroot=yes])
+dnl Help line for doxygen
+AC_ARG_ENABLE(doxygen,
+ AC_HELP_STRING([--disable-doxygen], [Build API docs via Doxygen]),
+ [wantdoxygen=$enableval], [wantdoxygen=yes])
+
dnl Check for man2html binary
AC_MSG_CHECKING(for support man2html)
if test x$wantman2html = xyes ; then
@@ -75,6 +80,27 @@ else
AC_MSG_RESULT(not requested by configure)
fi
+dnl Check for doxygen support
+AC_MSG_CHECKING(for support Doxygen)
+if test x$wantdoxygen = xyes ; then
+ AC_CHECK_PROGS([DOXYGEN], [doxygen] [doxygen binary])
+ AM_CONDITIONAL(HAS_DOXYGEN, test $DOXYGEN)
+ if test $DOXYGEN ; then
+ AC_DEFINE([HAS_DOXYGEN], [TRUE], [Enabled Doxygen Support])
+ AC_MSG_RESULT(yes)
+ DOXYSTATUS="yes, path: `which $DOXYGEN`"
+ else
+ AC_DEFINE([HAS_DOXYGEN], [FALSE], [Disabled Doxygen support])
+ AC_MSG_RESULT(no, doxygen missing)
+ DOXYSTATUS="doxygen binary not found"
+ fi
+else
+ AM_CONDITIONAL(HAS_DOXYGEN, test $DOXYGEN)
+ AC_DEFINE([HAS_DOXYGEN], [FALSE], [Not specified at configure line])
+ AC_MSG_RESULT(not requested by configure)
+ DOXYSTATUS="disabled by configure"
+fi
+
dnl Enable or disable Warning FLAGS during compile
AC_MSG_CHECKING(for more compiler warnings)
if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
@@ -165,4 +191,6 @@ pacman-$VERSION:
libalpm version: ${PM_VERSION}
debug support: ${debug}
+
+ Doxygen support : ${DOXYSTATUS}
"