summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2006-12-28 17:54:35 +0100
committerAaron Griffin <aaron@archlinux.org>2006-12-28 17:54:35 +0100
commit2546a35cd5d8671054b8ab99d760824fc5fc7b9d (patch)
tree3079aebea320203bdb9c0517ea5970dea698e2de /configure.ac
parent8eac207eadd36d47159f2f9946ea0e19b450ef4e (diff)
downloadpacman-2546a35cd5d8671054b8ab99d760824fc5fc7b9d.tar.gz
pacman-2546a35cd5d8671054b8ab99d760824fc5fc7b9d.tar.xz
Configuration changes:
* Added libdownload check in configure.ac * Added generation for mirrorlists in pacman.d NOTE: autoconf sucks for things like this, so gen-mirrorlist is required Dan McGee <dpmcgee@gmail.com>: * mirrorlist.in file Roman Kyrylych <roman.kyrylych@gmail.com>: * ukrainian mirror Jürgen Hötzel <juergen@hoetzel.info>: * conditional build for pacman.static
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 29 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index af741d1d..44627fd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,7 @@ AC_HEADER_STDC
AC_PROG_INSTALL
AC_CHECK_FUNCS([strverscmp])
AM_PROG_LIBTOOL
+AM_CONDITIONAL(LINKSTATIC, test "$enable_static" = "yes")
dnl Humor lowers blood pressure
AC_MSG_CHECKING(your blood pressure)
@@ -314,6 +315,14 @@ else
AC_MSG_ERROR("libarchive is needed to compile pacman!");
fi
+dnl Check for libdownload
+AC_CHECK_LIB([download], [downloadParseURL], [AC_CHECK_HEADER([download.h], [LIBDOWNLOAD='-ldownload'])])
+if test -n "$LIBDOWNLOAD"; then
+ LDFLAGS="$LDFLAGS $LIBDOWNLOAD"
+else
+ AC_MSG_ERROR("libdownload is needed to compile pacman!");
+fi
+
dnl Set config location
AC_MSG_CHECKING(for configuration file name)
if test -n "$configfile"; then
@@ -363,33 +372,38 @@ etc/Makefile
etc/makepkg.conf
etc/pacman.conf
etc/pacman.d/Makefile
+etc/pacman.d/mirrorlist
etc/abs/Makefile
bindings/perl/Makefile
bindings/python/Makefile
bindings/java/Makefile
Makefile
+],
+[
+ cd etc/pacman.d/
+ ./gen-mirrorlist.sh
])
echo "
pacman-$VERSION:
- prefix : ${prefix}
- source code location : ${srcdir}
- compiler : ${CC}
- compiler flags : ${CFLAGS}
+ prefix : ${prefix}
+ source code location : ${srcdir}
+ compiler : ${CC}
+ compiler flags : ${CFLAGS}
- libalpm version : ${PM_VERSION}
- pacman.conf location : ${configfile}
+ libalpm version : ${PM_VERSION}
+ pacman.conf location : ${configfile}
- Architecture CARCH : ${CARCH}
- Architecture used cflag : ${CARCHFLAGS}
- Architecture CHOST : ${CHOST}
+ Architecture CARCH : ${CARCH}
+ Architecture used cflag : ${CARCHFLAGS}
+ Architecture CHOST : ${CHOST}
- Doxygen support : ${DOXYSTATUS}
- Manpage localization : ${POSTATUS}
- Perl bindings : ${PERLSTATUS}
- Python bindings : ${PYTHONSTATUS}
- Java bindings : ${JAVASTATUS}
+ Doxygen support : ${DOXYSTATUS}
+ Manpage localization : ${POSTATUS}
+ Perl bindings : ${PERLSTATUS}
+ Python bindings : ${PYTHONSTATUS}
+ Java bindings : ${JAVASTATUS}
- debug support : ${debug}
+ debug support : ${debug}
"