summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2006-11-07 17:32:48 +0100
committerAaron Griffin <aaron@archlinux.org>2006-11-07 17:32:48 +0100
commit34931106d7653e73bb474e1d72aee4044f7d5a5d (patch)
tree3363f88bf77b284af3424bed72e2cddc78ef1a41 /configure.ac
parenta8e44ff00ad5dd2d3f59bdf4c024d94db3f23ae4 (diff)
downloadpacman-34931106d7653e73bb474e1d72aee4044f7d5a5d.tar.gz
pacman-34931106d7653e73bb474e1d72aee4044f7d5a5d.tar.xz
Added mcheck support for memory debugging
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7aac6c3..c87d17b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -319,6 +319,7 @@ AC_MSG_CHECKING(for debug mode request)
if test x$debug = xyes ; then
AM_CONDITIONAL(PACMAN_DEBUG, test x$debug = xyes)
CFLAGS="-g -Wall -Werror -std=c99 -DPACMAN_DEBUG"
+ LDFLAGS="$LDFLAGS -lmcheck"
AC_MSG_RESULT(yes)
else
AM_CONDITIONAL(PACMAN_DEBUG, test x$debug = xno)