summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2006-10-31 17:00:30 +0100
committerAaron Griffin <aaron@archlinux.org>2006-10-31 17:00:30 +0100
commit48ee3c4434efad0796521384661dc405cdd3db66 (patch)
treeeec674ee44e4531f7e7af6e722e86299b6e09041 /configure.ac
parent2930109416767cf4048954377bcccb665625d1d3 (diff)
downloadpacman-48ee3c4434efad0796521384661dc405cdd3db66.tar.gz
pacman-48ee3c4434efad0796521384661dc405cdd3db66.tar.xz
Removed user-CFLAGS during a debug build. Added -Wall to normal build(I like -Wall)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5d829ef7..c7aac6c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -318,11 +318,11 @@ dnl Enable or disable debug code
AC_MSG_CHECKING(for debug mode request)
if test x$debug = xyes ; then
AM_CONDITIONAL(PACMAN_DEBUG, test x$debug = xyes)
- CFLAGS="$CFLAGS -g -Wall -Werror -std=c99 -DPACMAN_DEBUG"
+ CFLAGS="-g -Wall -Werror -std=c99 -DPACMAN_DEBUG"
AC_MSG_RESULT(yes)
else
AM_CONDITIONAL(PACMAN_DEBUG, test x$debug = xno)
- CFLAGS="$CFLAGS -std=c99"
+ CFLAGS="$CFLAGS -Wall -std=c99"
AC_MSG_RESULT(no)
fi