summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2009-09-06 22:54:11 +0200
committerDan McGee <dan@archlinux.org>2009-09-06 22:54:11 +0200
commitb9dd8ce2334daea7e3949370c17c64e973b7c6db (patch)
treeb7a5a48da1764b93a69133a5ffbdb83dbb0c9be7 /configure.ac
parent65c1f06be5a9c4bdb197b61563da7c2e28162392 (diff)
parent1e51b81c6392125899c94761b5aa35bb6a0e032c (diff)
downloadpacman-b9dd8ce2334daea7e3949370c17c64e973b7c6db.tar.gz
pacman-b9dd8ce2334daea7e3949370c17c64e973b7c6db.tar.xz
Merge branch 'maint'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2164b9e..2c08d790 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,6 +144,11 @@ if test "x$internaldownload" = "xyes" ; then
# Check for a download library if it was actually requested
AC_CHECK_LIB([fetch], [fetchParseURL], ,
AC_MSG_ERROR([libfetch is needed to compile with internal download support]) )
+ # Check if libfetch supports conditional GET
+ # (version >=2.21, struct url has member last_modified)
+ AC_CHECK_MEMBER(struct url.last_modified, ,
+ AC_MSG_ERROR([libfetch must be version 2.21 or greater]),
+ [#include <fetch.h>] )
else
AC_MSG_RESULT(no)
fi