summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-02-11 04:28:04 +0100
committerAllan McRae <allan@archlinux.org>2013-02-13 02:50:33 +0100
commit1d0a69c655ccdeb1b87e0d2ebbe401acd7925351 (patch)
tree6a331ed71038980bcb026ddeef82585d7b93f991 /configure.ac
parent3fa2830829de2e3aa4bb916f164ae2fd75542ef3 (diff)
downloadpacman-1d0a69c655ccdeb1b87e0d2ebbe401acd7925351.tar.gz
pacman-1d0a69c655ccdeb1b87e0d2ebbe401acd7925351.tar.xz
Fix gpgme detection
The gpgme detection had a couple of issues which are fixed: 1) In some cases it would not error out when gpgme was missing and --with-gpgme was passed. 2) In some cases, the CFLAGS/LDFLAGS etc would not be properly restored. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a7364bab..1e1c37c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,13 +246,14 @@ AS_IF([test "x$with_gpgme" != "xno"],
unset GPGME_CFLAGS]
AS_IF([test "x$with_gpgme" = "xyes"],
[AC_MSG_FAILURE([*** gpgme >= 1.3.0 is needed for GPG signature support])])
- )],
- [with_gpgme=no])]
- [LIBS="$LIBS_save"
+ )
+
+ LIBS="$LIBS_save"
CPPFLAGS="$CPPFLAGS_save"
CFLAGS="$CFLAGS_save"
unset CPPFLAGS_save
- unset CFLAGS_save])
+ unset CFLAGS_save],)])
+
AS_IF([test "x$have_gpgme" = xno -a "x$with_gpgme" = xyes],
[AC_MSG_FAILURE([--with-gpgme was given, but gpgme was not found])])
AM_CONDITIONAL([HAVE_LIBGPGME], [test "x$have_gpgme" = "xyes"])