summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-09-19 05:33:06 +0200
committerAllan McRae <allan@archlinux.org>2012-11-27 06:16:15 +0100
commit768c8ba100f1bdef9bb99f8ca619d23f055877ce (patch)
treecb9da83150b02adaaca96bee864c10f473275faa /configure.ac
parent977489d9ab7d1d70ec95f14a2dcad0bac2e96242 (diff)
downloadpacman-768c8ba100f1bdef9bb99f8ca619d23f055877ce.tar.gz
pacman-768c8ba100f1bdef9bb99f8ca619d23f055877ce.tar.xz
configure.ac: cleanup duplication in --enable-git-version
Avoid adding our own messaging, as autoconf will add this for us with the result of the AC_CHECK_FILE test. Reuse the cache variable from autoconf to set our local variable. Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2d7580ea..eea2f98f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -424,13 +424,9 @@ AC_MSG_CHECKING(whether to use git version if available)
if test "x$wantgitver" = "xyes" ; then
AC_CHECK_PROGS([GIT], [git])
AC_CHECK_FILE([.git/], hasgitdir=yes)
+ usegitver=$ac_cv_file__git_
if test $GIT -a "x$hasgitdir" = "xyes"; then
- AC_MSG_RESULT([yes])
- usegitver=yes
AC_DEFINE([USE_GIT_VERSION], , [Use GIT version in version string])
- else
- AC_MSG_RESULT([no, git or .git dir missing])
- usegitver=no
fi
else
AC_MSG_RESULT([no, disabled by configure])