summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-01-20 12:56:57 +0100
committerAllan McRae <allan@archlinux.org>2013-01-28 14:38:46 +0100
commit89ecf8cabebfd13e50473fba7fb98f65a52b02d8 (patch)
treebb640857b2eb0d89ac3af16fcd4c02868e2acf22 /configure.ac
parente3d8197d67336b6e59ee184762271cf64431aca6 (diff)
downloadpacman-89ecf8cabebfd13e50473fba7fb98f65a52b02d8.tar.gz
pacman-89ecf8cabebfd13e50473fba7fb98f65a52b02d8.tar.xz
Make path to ldconfig configurable
The FHS (2.3) says having ldconfig in /sbin is optional and it is usually located in /usr/sbin. So /sbin/ldconfig should not be hard coded in pacman. Instead, provide a configure option --with-ldconfig that defaults to the current path. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa3305db..e2024212 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,12 @@ AC_ARG_WITH(scriptlet-shell,
[set the full path to the shell used to run install scriptlets]),
[SCRIPTLET_SHELL=$withval], [SCRIPTLET_SHELL=/bin/sh])
+# Help line for ldconfig path
+AC_ARG_WITH(ldconfig,
+ AS_HELP_STRING([--with-ldconfig=path],
+ [set the full path to ldconfig]),
+ [LDCONFIG=$withval], [LDCONFIG=/sbin/ldconfig])
+
# Help line for using OpenSSL
AC_ARG_WITH(openssl,
AS_HELP_STRING([--with-openssl], [use OpenSSL crypto implementations instead of internal routines]),
@@ -456,6 +462,10 @@ AC_DEFINE_UNQUOTED([DEBUGSUFFIX], "$DEBUGSUFFIX", [The suffix for debugging symb
# Set shell used by install scriptlets
AC_SUBST(SCRIPTLET_SHELL)
AC_DEFINE_UNQUOTED([SCRIPTLET_SHELL], "$SCRIPTLET_SHELL", [The full path of the shell used to run install scriptlets])
+# Set ldconfig path
+AC_SUBST(LDCONFIG)
+AC_DEFINE_UNQUOTED([LDCONFIG], "$LDCONFIG", [The full path to ldconfig])
+
# Configuration files
AC_CONFIG_FILES([