summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Miles <wmiles@sgl.com>2015-02-27 20:43:24 +0100
committerAllan McRae <allan@archlinux.org>2015-03-03 07:54:17 +0100
commit965539adbf15449533bc5fcb353774f7a4b62277 (patch)
treed05e0cf4753ac5bac8d4e340674451bfcac27c73 /configure.ac
parentbb94729c098f21ae850044a9201c1d5b92baea1f (diff)
downloadpacman-965539adbf15449533bc5fcb353774f7a4b62277.tar.gz
pacman-965539adbf15449533bc5fcb353774f7a4b62277.tar.xz
common: Avoid errors on systems that define strnlen but not strndup
Add a configure test for a system library supplied strnlen, and disable the embedded version in common if one is found. Signed-off-by: Will Miles <wmiles@sgl.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 735fdc34..359d61bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,8 +304,8 @@ AC_FUNC_MKTIME
AC_FUNC_STRCOLL
AC_CHECK_FUNCS([dup2 getcwd getmntinfo gettimeofday memmove memset \
mkdir realpath regcomp rmdir setenv setlocale strcasecmp \
- strchr strcspn strdup strerror strndup strrchr strsep strstr \
- strtol swprintf tcflush wcwidth uname])
+ strchr strcspn strdup strerror strndup strnlen strrchr \
+ strsep strstr strtol swprintf tcflush wcwidth uname])
AC_CHECK_MEMBERS([struct stat.st_blksize],,,[[#include <sys/stat.h>]])
# For the diskspace code