summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2016-12-11 02:12:52 +0100
committerAllan McRae <allan@archlinux.org>2017-01-04 04:59:14 +0100
commitd0a5766e24dd12d277bb9237e204f7c10f4981ac (patch)
treee0d1f204167acc97a9c2bd274153a7bb471aa14e /configure.ac
parent36eb35cacd9282fb063ed181b8754ef679ee302a (diff)
downloadpacman-d0a5766e24dd12d277bb9237e204f7c10f4981ac.tar.gz
pacman-d0a5766e24dd12d277bb9237e204f7c10f4981ac.tar.xz
configure.ac: Use POSIX compatible equality checks
Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 63f87d14..10e4415c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,13 +222,13 @@ PKG_CHECK_MODULES(LIBARCHIVE, [libarchive >= 2.8.0], ,
# Check for OpenSSL
have_openssl=no
have_nettle=no
-if test "x$with_crypto" == "xnettle"; then
+if test "x$with_crypto" = "xnettle"; then
PKG_CHECK_MODULES(NETTLE, [nettle],
[AC_DEFINE(HAVE_LIBNETTLE, 1, [Define whether to use nettle]) have_nettle=yes], have_nettle=no)
if test "x$have_nettle" = xno -a "x$with_crypto" = xnettle; then
AC_MSG_ERROR([*** nettle support requested but libraries not found])
fi
-else if test "x$with_crypto" == "xopenssl"; then
+else if test "x$with_crypto" = "xopenssl"; then
PKG_CHECK_MODULES(LIBSSL, [libcrypto],
[AC_DEFINE(HAVE_LIBSSL, 1, [Define if libcrypto is available]) have_openssl=yes], have_openssl=no)
if test "x$have_openssl" = xno; then