summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIvy Foster <ivy.foster@gmail.com>2016-08-30 22:33:56 +0200
committerAllan McRae <allan@archlinux.org>2016-08-31 05:01:07 +0200
commite28c5803bba8242ae98979700c5a034d3790255e (patch)
tree11f0ff6a66e1adca1da7d79ae9f2ee276d7a1c0d /configure.ac
parent1e2b39840660eabb393162cd2fb79423793ee36d (diff)
downloadpacman-e28c5803bba8242ae98979700c5a034d3790255e.tar.gz
pacman-e28c5803bba8242ae98979700c5a034d3790255e.tar.xz
Replace CURLOPT_PROGRESSFUNCTION with CURLOPT_XFERINFOFUNCTION
Curl 7.32.0 added CURLOPT_XFERINFOFUNCTION, which deprecates CURLOPT_PROGRESSFUNCTION and means less casting doubles to size_ts for alpm. This change has no user-facing nor frontend-facing effects. Signed-off-by: Ivy Foster <ivy.foster@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 51288e7f..d4a1c9f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,10 +232,10 @@ AM_CONDITIONAL(HAVE_LIBSSL, [test "$have_openssl" = "yes"])
# Check for libcurl
have_libcurl=no
if test "x$with_libcurl" != "xno"; then
- PKG_CHECK_MODULES(LIBCURL, [libcurl >= 7.19.4],
+ PKG_CHECK_MODULES(LIBCURL, [libcurl >= 7.32.0],
[AC_DEFINE(HAVE_LIBCURL, 1, [Define if libcurl is available]) have_libcurl=yes], have_libcurl=no)
if test "x$have_libcurl" = xno -a "x$with_libcurl" = xyes; then
- AC_MSG_ERROR([*** libcurl >= 7.19.4 is required for internal downloader support])
+ AC_MSG_ERROR([*** libcurl >= 7.32.0 is required for internal downloader support])
fi
fi
AM_CONDITIONAL(HAVE_LIBCURL, [test "$have_libcurl" = "yes"])