summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-07-02 00:40:43 +0200
committerDan McGee <dan@archlinux.org>2007-07-02 00:40:43 +0200
commitd70116bfbc535cac9eb941a570c34479e68a1b8d (patch)
tree48df01ba45aee0efafa04c5ba6fcb8af5f6874ae /doc/Makefile.am
parent2657a2bfb7847c8ac4dd5875979400d0d3fd89f6 (diff)
downloadpacman-d70116bfbc535cac9eb941a570c34479e68a1b8d.tar.gz
pacman-d70116bfbc535cac9eb941a570c34479e68a1b8d.tar.xz
Move Doxygen manpage generation to doc/ directory
Instead of doing the doxygen work in the libalpm/ dir, do it with the rest of the docs in the doc/ dir. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 7a614795..14caa0da 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -10,7 +10,14 @@ if HAS_DOXYGEN
man_MANS += $(wildcard man3/*.3)
endif
-EXTRA_DIST = $(man_MANS)
+EXTRA_DIST = $(man_MANS) Doxyfile
+
+if HAS_DOXYGEN
+all: doxygen.in
+
+doxygen.in:
+ doxygen $(srcdir)/Doxyfile
+endif
clean-local:
$(RM) man3/*.3