summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2019-10-24 08:54:31 +0200
committerAllan McRae <allan@archlinux.org>2019-10-30 01:05:28 +0100
commit866a5cd431e35803f85ad7a8045f0050c0b240e5 (patch)
tree1c9512aeac1d200d6d0d62d8ff8e6014cf58e1a3 /doc/Makefile.am
parent5c2059db28cc8d0dfa96f288517f2e10d1b6137a (diff)
downloadpacman-866a5cd431e35803f85ad7a8045f0050c0b240e5.tar.gz
pacman-866a5cd431e35803f85ad7a8045f0050c0b240e5.tar.xz
autotools: be more templated when getting list of doc dist files
Distribute asciidoc sources for all manpages instead of remembering to add files to both variables. Fixes regression in 377d47142f7aaa01ca782e6587f2d4caf663865b which broke building the website from a dist tarball: make: *** No rule to make target 'pacman-conf.8.html', needed by 'html'. Stop. (Technically this regression is already fixed by commit 942b909829d529409216939b36af11e8480726f5, but this is just going to keep happening, I suspect, so we should fix the root cause.) Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am15
1 files changed, 2 insertions, 13 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 195f0b14..c61110fc 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -21,6 +21,7 @@ MANPAGES = \
DOXYGEN_MANS = $(wildcard man3/*.3)
HTML_MANPAGES = $(addsuffix .html,$(MANPAGES))
+ASCIIDOC_MANPAGES = $(addsuffix .asciidoc,$(MANPAGES))
HTML_OTHER = \
index.html \
@@ -36,24 +37,12 @@ EXTRA_DIST = \
meson.build \
asciidoc.conf \
asciidoc-override.css \
- alpm-hooks.5.asciidoc \
- pacman.8.asciidoc \
- makepkg.8.asciidoc \
- makepkg-template.1.asciidoc \
- repo-add.8.asciidoc \
- vercmp.8.asciidoc \
- pacman-key.8.asciidoc \
- PKGBUILD.5.asciidoc \
PKGBUILD-example.txt \
- makepkg.conf.5.asciidoc \
- pacman.conf.5.asciidoc \
- BUILDINFO.5.asciidoc \
- pacman-conf.8.asciidoc \
- libalpm.3.asciidoc \
footer.asciidoc \
index.asciidoc \
submitting-patches.asciidoc \
translation-help.asciidoc \
+ $(ASCIIDOC_MANPAGES) \
$(MANPAGES) \
$(DOXYGEN_MANS)