summaryrefslogtreecommitdiffstats
path: root/doc/PKGBUILD-example.txt
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-09-17 04:10:44 +0200
committerDan McGee <dan@archlinux.org>2007-09-17 04:10:44 +0200
commit708488f6fe8bf5e06ae724243381b40586301633 (patch)
tree83042c703173107def709f65d65697e233225441 /doc/PKGBUILD-example.txt
parentb0aa51059233849b0a7ef8d6a851750776ce6645 (diff)
parentf131ee9c56b99429374dfcce583872ad9259ed96 (diff)
downloadpacman-708488f6fe8bf5e06ae724243381b40586301633.tar.gz
pacman-708488f6fe8bf5e06ae724243381b40586301633.tar.xz
Merge branch 'asciidoc' into working
We're getting close to release, so might as well do this now so people can actually update some of our documentation.
Diffstat (limited to 'doc/PKGBUILD-example.txt')
-rw-r--r--doc/PKGBUILD-example.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/doc/PKGBUILD-example.txt b/doc/PKGBUILD-example.txt
new file mode 100644
index 00000000..50b652bd
--- /dev/null
+++ b/doc/PKGBUILD-example.txt
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD,v 1.16 2006/06/20 07:03:04 tpowa Exp $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=module-init-tools
+pkgver=3.2.2
+pkgrel=3
+pkgdesc="Utilities for inserting and removing modules from the Linux kernel"
+arch=(i686 x86_64)
+url="http://www.kernel.org"
+license=('GPL')
+depends=('glibc')
+conflicts=('modutils')
+replaces=('modutils')
+backup=('etc/modprobe.conf' 'etc/modules.conf' 'etc/modprobe.devfs')
+source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2 \
+ makefile.patch modprobe.conf)
+md5sums=('a1ad0a09d3231673f70d631f3f5040e9' '47e14fda7a46668290d11d0444d81826'\
+ '6db59d41e04941a790f80c1a4432faef')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ patch -Np1 -i ../makefile.patch || return 1
+ sed -i 's|/usr/bin/install|/bin/install|g' install-with-care
+
+ ./configure --prefix=/usr --exec-prefix=/
+ make || return 1
+
+ INSTALL=/bin/install make DESTDIR="$pkgdir" install
+ install -D -m644 ../modprobe.conf "$pkgdir"/etc/modprobe.conf
+}
+
+# vim:set ts=2 sw=2 et: