summaryrefslogtreecommitdiffstats
path: root/doc/PKGBUILD.5.txt
diff options
context:
space:
mode:
authorAndrew Fyfe <andrew@neptune-one.net>2007-07-06 17:30:53 +0200
committerDan McGee <dan@archlinux.org>2007-07-09 19:47:56 +0200
commitf1fac6abfb676b081ee2d474ab3e15f6d07d0416 (patch)
tree63c1469b3217059805097e5227e9a3f57ff73c48 /doc/PKGBUILD.5.txt
parentab87657b937f3de392b1796e7f93c4008cc21f01 (diff)
downloadpacman-f1fac6abfb676b081ee2d474ab3e15f6d07d0416.tar.gz
pacman-f1fac6abfb676b081ee2d474ab3e15f6d07d0416.tar.xz
Update PKGBUILD example.
Signed-off-by: Andrew Fyfe <andrew@neptune-one.net>
Diffstat (limited to 'doc/PKGBUILD.5.txt')
-rw-r--r--doc/PKGBUILD.5.txt32
1 files changed, 3 insertions, 29 deletions
diff --git a/doc/PKGBUILD.5.txt b/doc/PKGBUILD.5.txt
index 3fa2f66b..fbb7886c 100644
--- a/doc/PKGBUILD.5.txt
+++ b/doc/PKGBUILD.5.txt
@@ -54,7 +54,7 @@ Options and Directives
found in /usr/share/licenses/common, then you should include the license
in the package itself and set license=("custom") or
license=("custom:LicenseName"). The license should be placed in
- $startdir/pkg/usr/share/licenses/$pkgname when building the package. If
+ $pkgdir/usr/share/licenses/$pkgname when building the package. If
multiple licenses are applicable for a package, list all of them:
licenses=('GPL' 'FDL').
@@ -220,37 +220,11 @@ install file is available in the ABS tree (/var/abs/install.proto).
Example
-------
-The following is an example PKGBUILD for the 'modutils' package. For more
+The following is an example PKGBUILD for the 'module-init-tools' package. For more
examples, look through the ABS tree.
-----
-# Maintainer: John Doe <johndoe@archlinux.org>
-# Contributor: Bill Smith <billsmith@archlinux.org>
-pkgname=modutils
-pkgver=2.4.25
-pkgrel=1
-pkgdesc="Utilities for inserting modules in the linux kernel"
-url="http://www.kernel.org"
-makedepends=('bash' 'mawk')
-depends=('glibc' 'zlib')
-backup=(etc/modules.conf)
-source=(ftp://ftp.kernel.org/pub/linux/utils/kernel/$pkgname/v2.4/$pkgname-$pkgver.tar.bz2
- modules.conf)
-arch=('i686')
-license=('GPL' 'custom') # dual licensed
-md5sums=('2c0cca3ef6330a187c6ef4fe41ecaa4d'
- '35175bee593a7cc7d6205584a94d8625')
-options=(!libtool)
-
-build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr --enable-insmod-static
- make || return 1
- make prefix=$startdir/pkg/usr install
- mv $startdir/pkg/usr/sbin $startdir/pkg
- mkdir -p $startdir/pkg/etc
- cp ../modules.conf $startdir/pkg/etc
-}
+include::PKGBUILD-example.txt[]
-----