summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-04-05 21:56:32 +0200
committerDan McGee <dan@archlinux.org>2010-05-05 06:32:13 +0200
commit2a6f3f06528149200e4fc8996c0c1e6d2bfa5480 (patch)
treeaac905d8cdaf36c58f3c6365f3a2089ed3e98617 /lib/libalpm/Makefile.am
parent8a6bbed98e11be3f619ef31e9e753d31081d11ee (diff)
downloadpacman-2a6f3f06528149200e4fc8996c0c1e6d2bfa5480.tar.gz
pacman-2a6f3f06528149200e4fc8996c0c1e6d2bfa5480.tar.xz
Move vercmp code into a separate file
This will facilitate using this object file on its own in the vercmp tool which will be done in a future commit. The net impact on the generated binaries should not be noticeable after this commit. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 871855ef..3473a73a 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -43,7 +43,8 @@ libalpm_la_SOURCES = \
remove.h remove.c \
sync.h sync.c \
trans.h trans.c \
- util.h util.c
+ util.h util.c \
+ version.c
libalpm_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION_INFO)
libalpm_la_LIBADD = $(LTLIBINTL)