summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorFlorian Weigelt <weigelt.florian@gmx.net>2016-10-11 13:20:11 +0200
committerAllan McRae <allan@archlinux.org>2016-10-22 12:50:55 +0200
commit603f087cd73aff0d39bf0ebfb23aaae5626cb814 (patch)
treec717f42475242b71304cc97f6755c28184d4f598 /lib/libalpm/Makefile.am
parent1f8f0bd9ac4c11cdc1b9506f9f64d8192ecad4ee (diff)
downloadpacman-603f087cd73aff0d39bf0ebfb23aaae5626cb814.tar.gz
pacman-603f087cd73aff0d39bf0ebfb23aaae5626cb814.tar.xz
Allow replacing libcrypto with libnettle in pacman
Add a --with-nettle configure option that directs pacman to use the libnettle hashing functions. Only one of the --with-libssl and --with-nettle configure options can be specified. [Allan: rewrote configure check] Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 945a6121..f4f20e61 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -65,13 +65,15 @@ libalpm_la_CFLAGS = \
$(GPGME_CFLAGS) \
$(LIBARCHIVE_CFLAGS) \
$(LIBCURL_CFLAGS) \
- $(LIBSSL_CFLAGS)
+ $(LIBSSL_CFLAGS) \
+ $(NETTLE_CFLAGS)
libalpm_la_LIBADD = \
$(LTLIBINTL) \
$(GPGME_LIBS) \
$(LIBARCHIVE_LIBS) \
$(LIBCURL_LIBS) \
- $(LIBSSL_LIBS)
+ $(LIBSSL_LIBS) \
+ $(NETTLE_LIBS)
# vim:set noet: