summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-10-07 22:00:24 +0200
committerDan McGee <dan@archlinux.org>2007-10-09 03:46:56 +0200
commit920b0d2049deb148efe89bfebda03d172b68c1f5 (patch)
tree885887ef8ac3ee6244fa8a2dfbc2fbc51df73145 /lib/libalpm/Makefile.am
parentb1613c26518abb55ae5fc970dccfb7e3c97398d1 (diff)
downloadpacman-920b0d2049deb148efe89bfebda03d172b68c1f5.tar.gz
pacman-920b0d2049deb148efe89bfebda03d172b68c1f5.tar.xz
Update usage of gcc __attribute__ flags
Change the default visibility of libalpm functions to internal instead of hidden- this allows for slightly better optimization because it tells GCC that the function can never be called outside of the current module (see http://gcc.gnu.org/onlinedocs/gcc/Function-Attributes.html). Also added some attributes to the pacman print functions so that they check the format strings being passed to them. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 37053707..69482396 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -7,7 +7,7 @@ include_HEADERS = alpm_list.h alpm.h
DEFS = -DLOCALEDIR=\"@localedir@\" @DEFS@
-AM_CFLAGS = -fvisibility=hidden -pedantic -D_GNU_SOURCE -fgnu89-inline
+AM_CFLAGS = -fvisibility=internal -pedantic -D_GNU_SOURCE -fgnu89-inline
libalpm_la_SOURCES = \
add.h add.c \