summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-01 04:19:03 +0100
committerDan McGee <dan@archlinux.org>2007-11-04 17:42:07 +0100
commitc26fe63ee5d84492bcfb36664af8a90619e6ded5 (patch)
tree591814b7bf5a0cc483f56968797e0c64556a81e7 /lib/libalpm/Makefile.am
parent8feccaed7861010caefa4f7b9824a612a78e3043 (diff)
downloadpacman-c26fe63ee5d84492bcfb36664af8a90619e6ded5.tar.gz
pacman-c26fe63ee5d84492bcfb36664af8a90619e6ded5.tar.xz
Add some more autoconf macros to filter our CFLAGS usage
Hopefully these new autoconf macros, with a little magic, will allow us to compile with any compiler and still choose the options we have available to us. Tested locally with gcc 4.2.2 and gcc 3.4.6; the latter doesn't support two of the items we previously had hardcoded in our CFLAGS. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index e42a0bd0..b84dcc33 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -7,7 +7,14 @@ include_HEADERS = alpm_list.h alpm.h
DEFS = -DLOCALEDIR=\"@localedir@\" @DEFS@
-AM_CFLAGS = -fvisibility=internal -pedantic -D_GNU_SOURCE -fgnu89-inline
+AM_CFLAGS = -pedantic -D_GNU_SOURCE
+
+if ENABLE_VISIBILITY_CC
+AM_CFLAGS += -fvisibility=internal
+endif
+if ENABLE_GNU89_INLINE_CC
+AM_CFLAGS += -fgnu89-inline
+endif
libalpm_la_SOURCES = \
add.h add.c \