summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-03-31 05:08:31 +0200
committerDave Reisner <dreisner@archlinux.org>2012-04-09 04:28:41 +0200
commitcb5b66367ddf4af05953a9486bddaaf105fb4f38 (patch)
treece786ce2390ec37634bb946c4d99c25c46e8be37 /lib/libalpm/Makefile.am
parentb2226ed11bca158ab32199b5899802a78a42f5aa (diff)
downloadpacman-cb5b66367ddf4af05953a9486bddaaf105fb4f38.tar.gz
pacman-cb5b66367ddf4af05953a9486bddaaf105fb4f38.tar.xz
buildsys: cleanup gpgme compile time check
- handle gpgme libs and cflags separately rather than appending to CFLAGS and LDFLAGS - be consistent in AC_LINK_IFELSE check for gpgme 1.3.0 (though this is irrelephant since we don't actually run) - be consistent with usage of "have" and "with" variables (this actually ends up reducing SLOC) - when voluntary detection fails, unset GPGME_CFLAGS and GPGME_LIBS - when requested support fails the version check, complain about the min version. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index c34079c7..31de62e3 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -67,12 +67,14 @@ libalpm_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION_INFO)
libalpm_la_CFLAGS = \
$(AM_CFLAGS) \
+ $(GPGME_CFLAGS) \
$(LIBARCHIVE_CFLAGS) \
$(LIBCURL_CFLAGS) \
$(LIBSSL_CFLAGS)
libalpm_la_LIBADD = \
$(LTLIBINTL) \
+ $(GPGME_LIBS) \
$(LIBARCHIVE_LIBS) \
$(LIBCURL_LIBS) \
$(LIBSSL_LIBS)