summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-04-15 04:01:30 +0200
committerDan McGee <dan@archlinux.org>2008-04-15 04:01:30 +0200
commitd685d0220fdb16097252bcf851ada5cf8400da0e (patch)
tree370f0844f163be0be6c254bab8b751e38b873ca4 /lib/libalpm/Makefile.am
parent4b7f7e2a59457aa881ae883b6d102f9fc62e2ed8 (diff)
downloadpacman-d685d0220fdb16097252bcf851ada5cf8400da0e.tar.gz
pacman-d685d0220fdb16097252bcf851ada5cf8400da0e.tar.xz
Fix gettext on non-Linux platforms
Linux includes all the gettext stuff in glibc, so there is no need for the libintl links which we failed to include in our linker variables. Update the makefiles which should enable NLS support on all platforms, including OS X and Cygwin. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 6549066f..00fc0b38 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -40,5 +40,6 @@ libalpm_la_SOURCES = \
util.h util.c
libalpm_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION_INFO)
+libalpm_la_LIBADD = $(LTLIBINTL)
# vim:set ts=2 sw=2 noet: