summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-04-11 23:45:43 +0200
committerDan McGee <dan@archlinux.org>2011-04-16 01:36:53 +0200
commitdd8cf0c12dd5e8bf951933723558eadc5c6f04af (patch)
tree1c0be33c958edd487de5da34510948b3af4e47ea /lib/libalpm/Makefile.am
parent8df7208d7b0f4cec2421e9e167baaae4dea27bf7 (diff)
downloadpacman-dd8cf0c12dd5e8bf951933723558eadc5c6f04af.tar.gz
pacman-dd8cf0c12dd5e8bf951933723558eadc5c6f04af.tar.xz
Move graph.h functions into graph.c
So we only need one copy in the final library, not one copy per time used. Ensure all necessary includes are in place (especially to get the right size of off_t each time it is compiled) by including "config.h" in the new graph.c. One small adjustment here makes the graph_free code more robust- ensure we don't have invalid pointers after each iteration by looking at the parents and children and adjusting accordingly. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index fb224a59..080ac195 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -36,7 +36,7 @@ libalpm_la_SOURCES = \
diskspace.h diskspace.c \
dload.h dload.c \
error.c \
- graph.h \
+ graph.h graph.c \
group.h group.c \
handle.h handle.c \
log.h log.c \