summaryrefslogtreecommitdiffstats
path: root/pactest/Makefile.am
diff options
context:
space:
mode:
authorHenning Garus <henning.garus@googlemail.com>2008-08-15 00:42:23 +0200
committerDan McGee <dan@archlinux.org>2008-08-24 01:00:37 +0200
commitec928faad350e2aad957256fb47cb10277990738 (patch)
tree239422936544a983a72a072e93c97d9e9a553b89 /pactest/Makefile.am
parent4b183bf9a9702b63cb8b031887d0f6bd38e538e3 (diff)
downloadpacman-ec928faad350e2aad957256fb47cb10277990738.tar.gz
pacman-ec928faad350e2aad957256fb47cb10277990738.tar.xz
Add autotools magic for pactests
Added a Makefile.am for the pactest/tests dir. This is a blatant ripoff of scripts/Makefile.am, which replaces predefined expressions in NAME.py.in pactests with configure variables. This can be used to write pactests which consider compile time options. Signed-off-by: Henning Garus <henning.garus@gmail.com> [Dan: autotools are tough, make a few adjustments for correctness] Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'pactest/Makefile.am')
-rw-r--r--pactest/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/pactest/Makefile.am b/pactest/Makefile.am
index ce611f78..64f9a22e 100644
--- a/pactest/Makefile.am
+++ b/pactest/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS = tests
+
check_SCRIPTS = \
pactest.py \
pmdb.py \
@@ -7,7 +9,6 @@ check_SCRIPTS = \
pmrule.py \
pmtest.py \
util.py \
- $(wildcard tests/*.py) \
vercmptest.sh
noinst_SCRIPTS = $(check_SCRIPTS)