summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorWill Miles <wmiles@sgl.com>2015-02-27 20:43:23 +0100
committerAllan McRae <allan@archlinux.org>2015-03-03 07:54:17 +0100
commitbb94729c098f21ae850044a9201c1d5b92baea1f (patch)
tree2f0ffe7f158bf4a8c458ebc78cc3cf35f7f63d4d /src/util/Makefile.am
parent8f92fe47a7c4d999271bc28ffbbeeea50d686813 (diff)
downloadpacman-bb94729c098f21ae850044a9201c1d5b92baea1f.tar.gz
pacman-bb94729c098f21ae850044a9201c1d5b92baea1f.tar.xz
util: Use util-common for strndup in pacsort and pactree
This small refactor reduces the number of replications of the local imeplementation of strndup. Signed-off-by: Will Miles <wmiles@sgl.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 25c025b5..936d7ffb 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -20,10 +20,10 @@ AM_CFLAGS = -pedantic -D_GNU_SOURCE $(WARNING_CFLAGS)
cleanupdelta_SOURCES = cleanupdelta.c
cleanupdelta_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
-pacsort_SOURCES = pacsort.c
+pacsort_SOURCES = pacsort.c util-common.c
pacsort_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
-pactree_SOURCES = pactree.c
+pactree_SOURCES = pactree.c util-common.c
pactree_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
testpkg_SOURCES = testpkg.c