summaryrefslogtreecommitdiffstats
path: root/test/pacman/meson.build
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2021-04-27 04:37:52 +0200
committerAllan McRae <allan@archlinux.org>2021-05-01 04:08:14 +0200
commit0ff94ae85d40efdc177e1852ef58848f82d14156 (patch)
treef647590d0803d9082b2b326be4fc6356cdf9d09e /test/pacman/meson.build
parent8faf749fd19aff0eb35eb7108d2fd379d3c9c3b9 (diff)
downloadpacman-0ff94ae85d40efdc177e1852ef58848f82d14156.tar.gz
pacman-0ff94ae85d40efdc177e1852ef58848f82d14156.tar.xz
fix downloading multiple urls with XferCommand
An extra break causes _alpm_download to break out of the payload loop as soon as it sees a successful url download with XferCommand. Fixes: FS#70608 - -U fails to download all files with XferCommand Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com>
Diffstat (limited to 'test/pacman/meson.build')
-rw-r--r--test/pacman/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/pacman/meson.build b/test/pacman/meson.build
index 6c28bd7d..0e75b3ee 100644
--- a/test/pacman/meson.build
+++ b/test/pacman/meson.build
@@ -333,6 +333,7 @@ pacman_tests = [
'tests/upgrade-download-404.py',
'tests/upgrade-download-pkg-and-sig-with-filename.py',
'tests/upgrade-download-pkg-and-sig-without-filename.py',
+ 'tests/upgrade-download-with-xfercommand.py',
]
xfail_tests = {
@@ -344,6 +345,7 @@ xfail_tests = {
'tests/sync403.py': true,
'tests/sync406.py': true,
'tests/upgrade078.py': true,
+ 'tests/upgrade-download-with-xfercommand.py': true,
}
foreach input : pacman_tests