summaryrefslogtreecommitdiffstats
path: root/test/scripts/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-04-26 04:27:19 +0200
committerDan McGee <dan@archlinux.org>2012-06-26 06:39:12 +0200
commitb58489d29a1898a4bff1b5da6ca4bfb14003dbfe (patch)
tree5c42f704cc671136ef43972cfdee1274e620e65f /test/scripts/Makefile.am
parente183522e3168c4a31103b3c7910fa8d29333fb5a (diff)
downloadpacman-b58489d29a1898a4bff1b5da6ca4bfb14003dbfe.tar.gz
pacman-b58489d29a1898a4bff1b5da6ca4bfb14003dbfe.tar.xz
scripts/library: add human_to_size
This is a bash wrapper around an awk function that parses human readable sizes and returns their representative values in bytes, as a string. A small test harness is added to validate the functionality. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'test/scripts/Makefile.am')
-rw-r--r--test/scripts/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/scripts/Makefile.am b/test/scripts/Makefile.am
index b949e880..d525d894 100644
--- a/test/scripts/Makefile.am
+++ b/test/scripts/Makefile.am
@@ -1,5 +1,6 @@
check_SCRIPTS = \
- parseopts_test.sh
+ parseopts_test.sh \
+ human_to_size_test.sh
noinst_SCRIPTS = $(check_SCRIPTS)