summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dc085429..ea3b0e07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,12 +11,14 @@ EXTRA_DIST = HACKING
pkgdatadir = ${datadir}/${PACKAGE}
dist_pkgdata_DATA = PKGBUILD.proto proto.install ChangeLog.proto
-# run the pactest test suite
-check-local: src/pacman
+# run the pactest test suite and vercmp tests
+check-local: pactest src/pacman src/util
$(PYTHON) $(top_srcdir)/pactest/pactest.py --debug=1 \
--test $(top_srcdir)/pactest/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
rm -rf $(top_builddir)/root
+ $(SH) $(top_srcdir)/pactest/vercmptest.sh \
+ $(top_builddir)/src/util/vercmp
# create the pacman DB and cache directories upon install
install-data-local: