summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 7602963f..0ef2a5da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,14 +1,12 @@
SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc pactest contrib
-DISTCHECK_CONFIGURE_FLAGS = --disable-fakeroot
+#DISTCHECK_CONFIGURE_FLAGS = --disable-fakeroot
# Some files automatically included, so they aren't specified below:
# AUTHORS, COPYING, NEWS, README
EXTRA_DIST = HACKING
-# TODO : figure out a way to get 'make distcheck' to build with
-# --disable-fakeroot so it actually passes tests
check-local: src/pacman
- python $(top_srcdir)/pactest/pactest.py --test $(top_srcdir)/pactest/tests/*.py -p $(top_builddir)/src/pacman/pacman --debug=1
+ python $(top_srcdir)/pactest/pactest.py --test $(top_srcdir)/pactest/tests/*.py -p $(top_builddir)/src/pacman/pacman
rm -rf $(top_builddir)/root