summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9515f2c..ae017d1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,11 @@ if test "x$with_openssl" != "xno"; then
fi
AM_CONDITIONAL(HAVE_LIBSSL, [test "$have_openssl" = "yes"])
+# Ensure one library for generating checksums is present
+if test "$have_openssl" != "yes"; then
+ AC_MSG_ERROR([*** no library for checksum generation found])
+fi
+
# Check for libcurl
have_libcurl=no
if test "x$with_libcurl" != "xno"; then