summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 359d61bf..60bb8376 100644
--- a/configure.ac
+++ b/configure.ac
@@ -165,6 +165,15 @@ AC_ARG_ENABLE(git-version,
# testing compilation against gpgme).
AC_SYS_LARGEFILE
+# Record large file flags in pkgconfig file
+if test "$enable_largefile" != no; then
+ if test "$ac_cv_sys_file_offset_bits" != 'no'; then
+ LFS_CFLAGS="-D_FILE_OFFSET_BITS=$ac_cv_sys_file_offset_bits"
+ fi
+fi
+AC_SUBST(LFS_CFLAGS)
+
+
# Checks for programs.
AC_PROG_AWK
AC_PROG_CC_C99