summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac60
1 files changed, 35 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index c672c66c..6ad5be50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,10 +93,13 @@ AC_ARG_WITH(openssl,
AS_HELP_STRING([--with-openssl], [use OpenSSL crypto implementations instead of internal routines]),
[], [with_openssl=check])
-# Help line for libfetch
-AC_ARG_WITH(fetch,
- AS_HELP_STRING([--with-fetch], [use libfetch as an internal downloader]),
- [], [with_fetch=check])
+# Help line for using gpgme
+AC_ARG_WITH(gpgme,
+ AS_HELP_STRING([--with-gpgme], [use GPGME for PGP signature verification]),
+ [], [with_gpgme=check])
+
+# Check for useable libcurl
+LIBCURL_CHECK_CONFIG([yes], [7.19.4], [with_libcurl=yes], [with_libcurl=no])
# Help line for documentation
AC_ARG_ENABLE(doc,
@@ -130,9 +133,12 @@ AC_CHECK_PROGS([PYTHON], [python2.7 python2.6 python2.5 python2 python], [false]
AC_PATH_PROGS([BASH_SHELL], [bash bash4 bash3], [false])
# find installed gettext
-AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT([external], [need-ngettext])
AM_GNU_GETTEXT_VERSION(0.13.1)
+AC_CHECK_LIB([m], [fabs], ,
+ AC_MSG_ERROR([libm is needed to compile pacman!]))
+
# Check for libarchive
AC_CHECK_LIB([archive], [archive_read_data], ,
AC_MSG_ERROR([libarchive is needed to compile pacman!]))
@@ -145,33 +151,29 @@ AS_IF([test "x$with_openssl" != "xno"],
[if test "x$with_openssl" != "xcheck"; then
AC_MSG_FAILURE([--with-openssl was given, but -lssl was not found])
fi],
- [-lcrypto])],
+ [-lcrypto])
+ with_openssl=$ac_cv_lib_ssl_MD5_Final],
AC_MSG_RESULT(no))
-AM_CONDITIONAL([HAVE_LIBSSL], [test "x$ac_cv_lib_ssl_MD5_Final" = "xyes"])
+AM_CONDITIONAL([HAVE_LIBSSL], [test "x$with_openssl" = "xyes"])
-# Enable or disable usage of libfetch
-AC_MSG_CHECKING(whether to link with libfetch)
-AS_IF([test "x$with_fetch" != "xno"],
+# Check for gpgme
+AC_MSG_CHECKING(whether to link with libgpgme)
+AS_IF([test "x$with_gpgme" != "xno"],
[AC_MSG_RESULT(yes)
- AC_CHECK_LIB([fetch], [fetchParseURL], ,
- [if test "x$with_fetch" != "xcheck"; then
- AC_MSG_FAILURE([--with-fetch was given, but -lfetch was not found])
+ AC_CHECK_LIB([gpgme], [gpgme_check_version], ,
+ [if test "x$with_gpgme" != "xcheck"; then
+ AC_MSG_FAILURE([--with-ggpme was given, but -lgpgme was not found])
fi],
- [-lcrypto -ldl])
- # Check if libfetch supports connnection caching which we use
- AS_IF([test "x$ac_cv_lib_fetch_fetchParseURL" = "xyes"],
- [AC_CHECK_DECL(fetchConnectionCacheInit, ,
- AC_MSG_ERROR([libfetch must be version 2.28 or greater]),
- [#include <fetch.h>])
- ])
- ],
+ [-lgpgme])
+ with_gpgme=$ac_cv_lib_gpgme_gpgme_check_version],
AC_MSG_RESULT(no))
-AM_CONDITIONAL([HAVE_LIBFETCH], [test "x$ac_cv_lib_fetch_fetchParseURL" = "xyes"])
+AM_CONDITIONAL([HAVE_LIBGPGME], [test "x$with_gpgme" = "xyes"])
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h glob.h libintl.h locale.h mntent.h string.h \
sys/ioctl.h sys/mount.h sys/param.h sys/statvfs.h \
- sys/time.h sys/types.h sys/ucred.h syslog.h wchar.h])
+ sys/time.h sys/types.h sys/ucred.h syslog.h termios.h \
+ wchar.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_INLINE
@@ -190,7 +192,7 @@ AC_FUNC_GETMNTENT
AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MKTIME
AC_CHECK_FUNCS([geteuid getmntinfo realpath regcomp strcasecmp \
- strndup strrchr strsep swprintf \
+ strndup strrchr strsep swprintf tcflush \
wcwidth uname])
# For the diskspace code
FS_STATS_TYPE
@@ -371,11 +373,12 @@ AC_CONFIG_FILES([
lib/libalpm/Makefile
lib/libalpm/po/Makefile.in
src/pacman/Makefile
+src/pacman/po/Makefile.in
src/util/Makefile
scripts/Makefile
+scripts/po/Makefile.in
doc/Makefile
etc/Makefile
-po/Makefile.in
test/pacman/Makefile
test/pacman/tests/Makefile
test/util/Makefile
@@ -395,9 +398,13 @@ ${PACKAGE_NAME}:
localstatedir : $(eval echo ${localstatedir})
database dir : $(eval echo ${localstatedir})/lib/pacman/
cache dir : $(eval echo ${localstatedir})/cache/pacman/pkg/
+
compiler : ${CC}
+ preprocessor flags : ${CPPFLAGS}
compiler flags : ${CFLAGS}
defines : ${DEFS}
+ library flags : ${LIBS}
+ linker flags : ${LDFLAGS}
Architecture : ${CARCH}
Architecture flags : ${CARCHFLAGS}
@@ -417,6 +424,9 @@ ${PACKAGE_NAME}:
build script name : ${BUILDSCRIPT}
Compilation options:
+ Use libcurl : ${with_libcurl}
+ Use GPGME : ${with_gpgme}
+ Use OpenSSL : ${with_openssl}
Run make in doc/ dir : ${wantdoc} ${asciidoc}
Doxygen support : ${usedoxygen}
debug support : ${debug}