summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5483ee15..7fe696a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,11 @@ LT_INIT
LIB_VERSION=`expr lib_current - lib_age`.lib_age.lib_revision
LIB_VERSION_INFO="lib_current:lib_revision:lib_age"
+# Respect empty CFLAGS during compiler tests
+if test "x$CFLAGS" != "x"; then
+ CFLAGS=""
+fi
+
# Set subsitution values for version stuff in Makefiles and anywhere else,
# and put LIB_VERSION in config.h
AC_SUBST(LIB_VERSION)