summaryrefslogtreecommitdiffstats
path: root/etc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index 733526c3..7ad9178e 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -13,6 +13,7 @@ MOSTLYCLEANFILES = $(dist_sysconf_DATA)
#### Taken from the autoconf scripts Makefile.am ####
edit = sed \
-e 's|@sysconfdir[@]|$(sysconfdir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
-e 's|@prefix[@]|$(prefix)|g' \
-e 's|@PACKAGE_VERSION[@]|$(PACKAGE_VERSION)|g' \
-e 's|@PACKAGE_NAME[@]|$(PACKAGE_NAME)|g' \
@@ -21,7 +22,8 @@ edit = sed \
-e 's|@CARCH[@]|$(CARCH)|g' \
-e 's|@CHOST[@]|$(CHOST)|g' \
-e 's|@ARCHSWITCH[@]|$(ARCHSWITCH)|g' \
- -e 's|@CARCHFLAGS[@]|$(CARCHFLAGS)|g'
+ -e 's|@CARCHFLAGS[@]|$(CARCHFLAGS)|g' \
+ -e 's|@ROOTDIR[@]|$(ROOTDIR)|g'
$(dist_sysconf_DATA): Makefile
rm -f $@ $@.tmp