summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 3473a73a..1bda5714 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -25,27 +25,33 @@ libalpm_la_SOURCES = \
alpm.h alpm.c \
alpm_list.h alpm_list.c \
backup.h backup.c \
- be_files.c \
+ be_local.c \
be_package.c \
- cache.h cache.c \
+ be_sync.c \
conflict.h conflict.c \
db.h db.c \
delta.h delta.c \
deps.h deps.c \
+ diskspace.h diskspace.c \
dload.h dload.c \
error.c \
graph.h \
group.h group.c \
handle.h handle.c \
log.h log.c \
- md5.h md5.c \
package.h package.c \
+ pkghash.h pkghash.c \
remove.h remove.c \
sync.h sync.c \
trans.h trans.c \
util.h util.c \
version.c
+if !HAVE_LIBSSL
+libalpm_la_SOURCES += \
+ md5.h md5.c
+endif
+
libalpm_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION_INFO)
libalpm_la_LIBADD = $(LTLIBINTL)