summaryrefslogtreecommitdiffstats
path: root/test/pacman/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/pacman/tests/Makefile.am')
-rw-r--r--test/pacman/tests/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/test/pacman/tests/Makefile.am b/test/pacman/tests/Makefile.am
new file mode 100644
index 00000000..b793687b
--- /dev/null
+++ b/test/pacman/tests/Makefile.am
@@ -0,0 +1,27 @@
+CONFTESTS = $(patsubst %py.in,%py,$(wildcard *.py.in))
+
+check_SCRIPTS = \
+ $(wildcard *.py) \
+ $(CONFTESTS)
+
+noinst_SCRIPTS = $(check_SCRIPTS)
+
+EXTRA_DIST = $(check_SCRIPTS)
+
+CLEANFILES = $(CONFTESTS)
+
+#### Taken from the autoconf scripts Makefile.am ####
+edit = sed \
+ -e 's|@LIBS[@]|$(LIBS)|g' \
+ -e 's|@configure_input[@]|Generated from $@.in; do not edit by hand.|g'
+
+
+$(CONFTESTS): Makefile
+ @echo ' ' GEN $@;
+ @rm -f $@ $@.tmp
+ @test -f $(srcdir)/$@.in && $(edit) $(srcdir)/$@.in >$@.tmp || true
+ @test -f $@.tmp || false
+ @chmod a-w $@.tmp
+ @mv $@.tmp $@
+
+# vim:set ts=2 sw=2 noet: