summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/alpm.c
AgeCommit message (Collapse)AuthorFilesLines
2007-04-04This change does two things:Aaron Griffin1-16/+25
* Prefer case-insensitive config settings. In the future case-insensitivity may be enforced. * Provides a fix for the tr_TR locale by checking the case-insensitive version first. This is more elegant than setting the 'C' locale for tr_TR. Also added a 'RootDir' config option to match CacheDir and DBPath
2007-03-11* Fix group comparison issue and associated compilation warnings by usingDan McGee1-1/+1
the alpm strcmp operation which takes void* references. * We had this great visibility patch, but never actually took advantage of it. Added the right compile flag to make it work and added some more SYMEXPORTs where necessary to have a successful compile.
2007-03-06* Added missing header include guards in md5.h and sha1.h.Dan McGee1-1/+1
* Some header cleanup on the pacman side of things - we had alpm.h instead alpm_list.h in a few headers. * removed an extra slash in path-building snprintf in server.c.
2007-03-05This commit looks much more monumental than it is. Almost all just #includeDan McGee1-4/+6
reordering and adding ones that were forgotten (noticed when trying to compile after reordering). * Updated the HACKING file to include information on #include usage. * print -> vprint in "making dir" function in pactest.
2007-03-05* Failure to #include config.h cost us here, we lost all NLS in alpm.c.Dan McGee1-0/+1
2007-03-04* Fixed a whole mess of extra '/' pathing issues when a different root isAaron Griffin1-2/+2
specified * Use db->path when appropriate * Commented out the FAKEROOT checks in libalpm. This should never ever be done. TODO test this quite a bit, as this will never cause the transactions to fail if RW operations are requested... right now it is totally up to the front end to decide when to fail * Use realpath() to canonicalize the root path when specified, so _alpm_makepath() doesn't freak out * Fixed some output/indent of MDFile and SHAFile algorithms * More efficient sprintf() usage in MDFile/SHAFile * Added real error output to _alpm_makepath
2007-03-03Big commit this time:Aaron Griffin1-56/+50
* Moved entirely to alpm_pkg_get_* accessors, to read data on demand * Mostly removed the INFRQ_ parameters from outside the be_files backend (making the backend more extensible in the long run) * packages created from _alpm_db_scan now have the db and origin set (making accessors actually work for these packages) * removed _alpm_db_ensure_pkgcache * totally revamped the _alpm_checkconflicts function, making it cleaner and easier to read (and thus fix in the long run) - maintainable code ftw NOTE: feel free to rename the functions... I couldn't think of anything better * removed an extra loop in sync.c:find_replacements - no sense in looping over an entire DB while strcmp'ing the name, when we have get_pkgfromcache Other: * package struct "license" -> "licenses" * Created _alpm_sync_find (duplicate code in some places, find_pkginsync * Minor const correctness changes along the way * fixed a couple extra '/' pathing issues (non-issues really) * removed a duplicate pkg_cmp function
2007-03-01* Modified values of INFRQ_* options so we start at 0x01 and not 0x00. ThisDan McGee1-4/+4
allows for the same bit operators to be used across the board on pkg_get operations. * Changed name of INFRQ_NONE -> INFRQ_BASE to more clearly reflect what it does (loads pkg name and version). * Added a few missing things on package functions, such as SYMEXPORT and ALPM_LOG_FUNC. * Slight updates to pmenv to print 'pass' and 'fail' instead of 'passed' and 'failed'. Keeps output a bit more concise. * Fixed a doxygen comment spelling error. :P
2007-02-26* Enforce const char* params when using stringsAaron Griffin1-4/+4
* Unified some functions names "package" -> "pkg" for consistency * Removed the goofy 'faketarget' stuff used for dep testing * Renamed alpm_pkg_isin -> alpm_pkg_find * Renamed alpm_db_readpkg -> alpm_db_get_pkg
2007-02-14* Removed needless checking of package infolevel- leave it to theDan McGee1-16/+6
alpm_pkg_get functions to do this.
2007-02-13Removed desc_localized for the time being. We don't have localizedAaron Griffin1-0/+1
descriptions, nor do we actually build them with the newest makepkg. The actual implementation in here seems like it could be done better, and it soaks a large amount of CPU time according to profilers.
2007-02-12* Updated the README fileAaron Griffin1-4/+2
* Removed the handle->needles param. It's not needed not that alpm_list_t is public
2007-02-10* 'add' percentages now cap at 100% (see the comment)Aaron Griffin1-4/+5
* downloaded packages now pass ONLY the package name to the callback
2007-02-09* Fix compile errors/warnings.Dan McGee1-1/+0
* Update .cvsignore files a bit.
2007-02-09* I made "alpm_versioncmp" public a while back, without noticing this was ↵Aaron Griffin1-20/+2
already done (alpm_pkg_vercmp). I dropped this change, making versioncmp "private" again. (alpm_versioncmp -> _alpm_versioncmp, hidden symbol) * Make alpm_get_upgrades use the same version check that -Su and -S use.
2007-02-07Spruced up the TODOs a bit, got rid of some of them since a lot of it wasDan McGee1-13/+11
duplicate anyway. Also removed the last of the ORE tags and replaced them with TODOs.
2007-02-07Copy/pasta error in alpm_get_upgrades that caused a segfaultAaron Griffin1-1/+1
2007-02-04Implemented a crappy version of -Qu (query upgrades). This simply outputs theAaron Griffin1-0/+154
packages to be upgraded in a -Su operation. Much of the code is duplicated from sync.c. TODO: move the implementation to upgrades.c, and reimplement the sync_sysupgrade function in terms of this: trans->packages = alpm_get_upgrades();
2007-01-31Debug logging changes:Aaron Griffin1-17/+7
* The --debug params were goofy. New setup allows --debug without params, --debug=<level> where level 1=debug output, 2=debug and download output, 3=debug, download, and function tracing output. This seems more sane to me. * Removed PM_LOG_FLOW1 and PM_LOG_FLOW2. They were just confusing. When adding new functions, it is near impossible to determin if your output should be "flow1" or "flow2" without tracking all the way up the call chain. Rarely would one ever say "ok, lets just show "flow2" output. These have both been replaced with PM_LOG_DEBUG * Removed the need for the root parameter on alpm_initialize. it is now defaulted to PM_ROOT just like dbpath and cachedir. This allows alpm to be initialized BEFORE option parsing in the front end, saving us some duplicate variables in the frontend. * Cleaned up front end variables due to early alpm_initialize call.
2007-01-30K. Piche <kevin.piche@cgi.com>Aaron Griffin1-0/+52
* ALPM_LOG_FUNCTION macro and all the great work to add this macro everywhere
2007-01-30K. Piche <kpiche@rogers.com>Aaron Griffin1-27/+27
* gcc visiblity changes Also modified _alpm_versioncmp -> alpm_versioncmp (public function) as per K. Piche's suggestions
2007-01-30Discussed on IRC for a bit, this makes the following changes for clarity:Dan McGee1-1/+1
* alpm_list_is_in --> alpm_list_find * alpm_list_is_strin --> alpm_list_find_str * Flip parameters of both functions to be inline with rest of alpm_list. First commit, woohoo.
2007-01-26Dan McGee <dpmcgee@gmail.com>Aaron Griffin1-2/+2
* Lots of code cleanup, and type fixes * Make 'makeworld' a bit more in-line with the other stuff * Make -Si and -Qi operations appear the same
2007-01-24This mainly deals with code clarity- removing currently unneededAaron Griffin1-2/+4
optimizations in order to make the code much more readable and type-checkable. Every enum in the library now has it's own type that should be used instead of the generic 'unsigned char'. In addition, several #define statements dealing with constants were converted to enums. Signed-off-by: Dan McGee <dpmcgee@gmail.com>
2007-01-19Preliminary checkin for alpm_list conversionAaron Griffin1-89/+14
* renamed pmlist_t -> alpm_list_t * made alpm_list_t a public type (alpm_list.h header) * removed additional storage for registered DBs in pacman source * some code cleanup * removed duplicate (pm)list_display functions from pacman source * misc code cleanup
2007-01-18Dan McGee <dpmcgee@gmail.com>Aaron Griffin1-1/+1
* Removed some unnecessary headers and library links * Made things static if possible * Cleaned up makefiles a bit * Fixed some old comments in the code * Fixed some errors the static code checker splint pointed out * Backwards arguments in a memset call in _alpm_db_read (could have been worse) * Other various small fixes Other: * Default to 80 columns when getcols cannot determine display width * Removal of ._install as a valid install file in packages
2007-01-11* Dan McGee <dpmcgee@gmail.com>Aaron Griffin1-28/+8
Documentation cleanup
2007-01-03* bug fix FS#6100 - fix --print-uris outputAaron Griffin1-1/+4
2006-12-01* Cosmetic changes and typo fixesAaron Griffin1-2/+7
* IgnorePkg and --ignore work again * Partial changes to support removal of conflicts for -U and -A (INCOMPLETE)
2006-11-22* Completed getinfo api changes (pmmissing_t, pmtrans_t, etc)Aaron Griffin1-73/+0
* Modified some dependancy checking * Changed "performing local database upgrade" message to be more clear * Change 'usize' to 'isize' in database files * Scriptlet output is now sent to pacman's log file * Limited some debugging output to be more clear
2006-11-20* repo-add script - to add entries to a db file directly from package data ↵Aaron Griffin1-295/+45
(no PKGBUILD) * libalpm api changes - move from a _getinfo(p, WHAT_WE_WANT) scheme to a typesafe _get_what_we_want(p) scheme [not 100% complete yet] * some const correctness changes * removal of PM_* types in alpm.h in favor of the pm*_t types used throughout libalpm
2006-11-15* Initial changes to gensync - makepkg changes were not checked in from anotherAaron Griffin1-0/+39
machine - still pending * Addition of _alpm_pkg_makefilename to simplify the with/without -ARCH prefix scheme we're going with for the interim
2006-11-14* Numerous mini valgrind fixes.Aaron Griffin1-3/+16
* Addition of hacky architecture check in the _splitname function * Removal of libfetch from the archlinux proper - it has been renamed to libdownload and can be found at http://phraktured.net/libdownload * Merge of _some_ of the Frugalware makepkg change - this may still be incomplete * Removal of libftp from cvs proper * PKGBUILD manpage now says 'PKGBUILD' instead of FrugalBuild (he he)
2006-11-08* Improved mcheck outputAaron Griffin1-2/+2
* Added minor libalpm const correctness * Mini-memory fixes
2006-11-08* Fixed an error message that should be a debug messageAaron Griffin1-4/+6
* Fixed "the big segfault" - dbs_sync list was being modified while iterating * over the list, big No-No. Now using a while loop over alpm_list_count.
2006-11-01Fixed pacman -U:Aaron Griffin1-22/+22
* Accidental database read of a file-based package (whoops) * Proper fetching of url-based -U or -A Removed some newlines from _alpm_log calls, to make debug output more concise
2006-10-31Numerous changes:Aaron Griffin1-22/+19
* Furthered the "lazy caching" to force the pkgcache to read nothing (INFRQ_NONE) by default. Anything requiring package data should now check the infolevel of each package and attempt to update it. This could be ironed out a bit more later (by using the front-end get_info function * Switched to libfetch. Drastic changes to the download code and the callback progress bar functions. Also fixed the return value of _alpm_downloadfiles_forreal. Downloading now supports http, ftp, https, and files urls, along with 'mtime's and numerous other fancy features from libfetch.
2006-10-27Fri Oct 27 21:54:32 CEST 2006 VMiklos <vmiklos@frugalware.org>Aaron Griffin1-1/+6
* alpm_parse_config(): add missing sanity checks From: http://darcs.frugalware.org/patches/pacman/20061027195432-e2957-0dcda6bdb2d7516d6a5047185bc14ccdf3fb83fc.patch
2006-10-25Moved downloaded db unpacking to the backend files, to easier allow conversionAaron Griffin1-14/+3
from db to whatever format we need.
2006-10-24Added PM_DLFNM_LEN define, via VMiklosAaron Griffin1-0/+5
http://darcs.frugalware.org/darcsweb/darcsweb.cgi?r=pacman;a=commitdiff;h=20061023154138-e2957-de4837230b091cbc2136306e1c55a4b79cc72fc8.gz
2006-10-21Fixes from frugalware: few 'typos' included while patchingAaron Griffin1-1/+2
Also re-added Judd's dependancy fix in libalpm/deps.c
2006-10-21Minor changes:Aaron Griffin1-1/+1
* Moved the pmhandle_t extern decl around * Fixed a doxygen complaint
2006-10-20A handful of minor changes:Aaron Griffin1-71/+23
* Removed the PMList typedef, in favor of the same naming scheme other structs use 'pmlist_t' * Added a time stamp on debug output, to make it more informational * Moved alpm_db_register to _alpm_db_register, making the public function not take a callback parameter
2006-10-19From VMiklos <vmiklos@frugalware.org>Aaron Griffin1-3/+3
* alpm_db_update() fix up the level parameter till now when it was "1", it meant false, which was not in sync with the C logic :)
2006-10-19Fixed doxygen commentsAaron Griffin1-6/+6
2006-10-15Merged frugalware changes (too many to list). Also added some config fileAaron Griffin1-84/+525
handling changes (support [sections] to carry over to included files - this helps with backwards compatibility with existing pacman config files)
2006-07-15Patch from FW: Better control over CTRL-C interruptions -- do not leave the ↵Judd Vinet1-0/+8
DB in an inconsistent state
2006-05-15first stage of i18n stuff from VMiklosJudd Vinet1-17/+18
2006-03-21fixed a regression (patch from VMiklos <vmiklos@frugalware.org>)Aurelien Foret1-3/+1
2006-03-14put back treename in db->pathAurelien Foret1-7/+10