summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/db.c
AgeCommit message (Collapse)AuthorFilesLines
2007-03-09* Two fixes when running under a new root (-r|--root)Aaron Griffin1-1/+1
- Check EACCES in can_remove_file, to verify - we're only checking for a read-only FS here... if write permissions fail, we can still remove it - Switched the message when creating DB directories from an error to a debug message * Fix the dep tests once and for all (it wasn't working for provides=() packages)
2007-03-05This commit looks much more monumental than it is. Almost all just #includeDan McGee1-7/+9
reordering and adding ones that were forgotten (noticed when trying to compile after reordering). * Updated the HACKING file to include information on #include usage. * print -> vprint in "making dir" function in pactest.
2007-03-04* Fixed a whole mess of extra '/' pathing issues when a different root isAaron Griffin1-1/+1
specified * Use db->path when appropriate * Commented out the FAKEROOT checks in libalpm. This should never ever be done. TODO test this quite a bit, as this will never cause the transactions to fail if RW operations are requested... right now it is totally up to the front end to decide when to fail * Use realpath() to canonicalize the root path when specified, so _alpm_makepath() doesn't freak out * Fixed some output/indent of MDFile and SHAFile algorithms * More efficient sprintf() usage in MDFile/SHAFile * Added real error output to _alpm_makepath
2007-03-03Big commit this time:Aaron Griffin1-8/+8
* Moved entirely to alpm_pkg_get_* accessors, to read data on demand * Mostly removed the INFRQ_ parameters from outside the be_files backend (making the backend more extensible in the long run) * packages created from _alpm_db_scan now have the db and origin set (making accessors actually work for these packages) * removed _alpm_db_ensure_pkgcache * totally revamped the _alpm_checkconflicts function, making it cleaner and easier to read (and thus fix in the long run) - maintainable code ftw NOTE: feel free to rename the functions... I couldn't think of anything better * removed an extra loop in sync.c:find_replacements - no sense in looping over an entire DB while strcmp'ing the name, when we have get_pkgfromcache Other: * package struct "license" -> "licenses" * Created _alpm_sync_find (duplicate code in some places, find_pkginsync * Minor const correctness changes along the way * fixed a couple extra '/' pathing issues (non-issues really) * removed a duplicate pkg_cmp function
2007-03-01* Fix up _alpm_db_free, remove use of void*.Dan McGee1-4/+2
2007-02-27* db search optimization- why don't we compile the regex once instead of onceDan McGee1-7/+11
per package.
2007-02-26* Enforce const char* params when using stringsAaron Griffin1-2/+2
* Unified some functions names "package" -> "pkg" for consistency * Removed the goofy 'faketarget' stuff used for dep testing * Renamed alpm_pkg_isin -> alpm_pkg_find * Renamed alpm_db_readpkg -> alpm_db_get_pkg
2007-02-21* Re-added a compare function for syncpkg's - it was removed without thinkingAaron Griffin1-1/+1
properly * Error when re-reading the DB for replacements, wrong info level * Removed an duplicate debug message "checking for package replacements" * Check ignorepkg for REAL upgrades... * Properly check the NOSAVE flag * some unlink_file (remove.c) cleanup * fix indent level on handle.c * Force libalpm paths to end with a '/' char * Fixed 'target' looping in conflict.c (pmsyncpkg_t, not pmpkg_t) * Added some debug output to cache and db scanning ** All pactest tests succeed again, yay **
2007-01-31Debug logging changes:Aaron Griffin1-2/+2
* The --debug params were goofy. New setup allows --debug without params, --debug=<level> where level 1=debug output, 2=debug and download output, 3=debug, download, and function tracing output. This seems more sane to me. * Removed PM_LOG_FLOW1 and PM_LOG_FLOW2. They were just confusing. When adding new functions, it is near impossible to determin if your output should be "flow1" or "flow2" without tracking all the way up the call chain. Rarely would one ever say "ok, lets just show "flow2" output. These have both been replaced with PM_LOG_DEBUG * Removed the need for the root parameter on alpm_initialize. it is now defaulted to PM_ROOT just like dbpath and cachedir. This allows alpm to be initialized BEFORE option parsing in the front end, saving us some duplicate variables in the frontend. * Cleaned up front end variables due to early alpm_initialize call.
2007-01-30K. Piche <kevin.piche@cgi.com>Aaron Griffin1-0/+13
* ALPM_LOG_FUNCTION macro and all the great work to add this macro everywhere
2007-01-30K. Piche <kpiche@rogers.com>Aaron Griffin1-1/+1
* gcc visiblity changes Also modified _alpm_versioncmp -> alpm_versioncmp (public function) as per K. Piche's suggestions
2007-01-24This mainly deals with code clarity- removing currently unneededAaron Griffin1-1/+1
optimizations in order to make the code much more readable and type-checkable. Every enum in the library now has it's own type that should be used instead of the generic 'unsigned char'. In addition, several #define statements dealing with constants were converted to enums. Signed-off-by: Dan McGee <dpmcgee@gmail.com>
2007-01-23* Added some calloc calls to replace the malloc-then-set-to-zero functionalityAaron Griffin1-6/+2
* Fixed -Ss output so as not to call alpm_list_getdata with a NULl list * Added a NULL check in alpm_list_getdata * Fixed alpm_list_add_sorted to properly handle a new / beginning insertions
2007-01-19Preliminary checkin for alpm_list conversionAaron Griffin1-5/+5
* renamed pmlist_t -> alpm_list_t * made alpm_list_t a public type (alpm_list.h header) * removed additional storage for registered DBs in pacman source * some code cleanup * removed duplicate (pm)list_display functions from pacman source * misc code cleanup
2007-01-17Jürgen Hötzel <juergen@hoetzel.info>Aaron Griffin1-41/+20
* avoid repeated regex compilations (regex for search string do not change while scanning the package database) * remove needless string duplication (regex function do not change target string nor free them) * code cleanup This patch improves search performance: bash-3.2$ time ./src/pacman/pacman.static.old -Ss "(database|web).*server" >/dev/null real 0m1.026s user 0m0.544s sys 0m0.208s bash-3.2$ time ./src/pacman/pacman.static -Ss "(database|web).*server" >/dev/null real 0m0.777s user 0m0.456s sys 0m0.128s bash-3.2$
2006-12-21* modeline fixes / reformattingAaron Griffin1-1/+1
* formatting / indentation fixes * makepkg: Dan McGee <dpmcgee@gmail.com> - integrity check fix Jürgen Hötzel <juergen@hoetzel.info> - EUID usage and "x$foo" check revamp
2006-12-01* Cosmetic changes and typo fixesAaron Griffin1-1/+1
* IgnorePkg and --ignore work again * Partial changes to support removal of conflicts for -U and -A (INCOMPLETE)
2006-11-20* repo-add script - to add entries to a db file directly from package data ↵Aaron Griffin1-0/+25
(no PKGBUILD) * libalpm api changes - move from a _getinfo(p, WHAT_WE_WANT) scheme to a typesafe _get_what_we_want(p) scheme [not 100% complete yet] * some const correctness changes * removal of PM_* types in alpm.h in favor of the pm*_t types used throughout libalpm
2006-11-01Fixed pacman -U:Aaron Griffin1-3/+3
* Accidental database read of a file-based package (whoops) * Proper fetching of url-based -U or -A Removed some newlines from _alpm_log calls, to make debug output more concise
2006-10-31Numerous changes:Aaron Griffin1-3/+3
* Furthered the "lazy caching" to force the pkgcache to read nothing (INFRQ_NONE) by default. Anything requiring package data should now check the infolevel of each package and attempt to update it. This could be ironed out a bit more later (by using the front-end get_info function * Switched to libfetch. Drastic changes to the download code and the callback progress bar functions. Also fixed the return value of _alpm_downloadfiles_forreal. Downloading now supports http, ftp, https, and files urls, along with 'mtime's and numerous other fancy features from libfetch.
2006-10-21Fixes from frugalware: few 'typos' included while patchingAaron Griffin1-1/+0
Also re-added Judd's dependancy fix in libalpm/deps.c
2006-10-21Minor changes:Aaron Griffin1-2/+0
* Moved the pmhandle_t extern decl around * Fixed a doxygen complaint
2006-10-20A handful of minor changes:Aaron Griffin1-5/+64
* Removed the PMList typedef, in favor of the same naming scheme other structs use 'pmlist_t' * Added a time stamp on debug output, to make it more informational * Moved alpm_db_register to _alpm_db_register, making the public function not take a callback parameter
2006-10-15Merged frugalware changes (too many to list). Also added some config fileAaron Griffin1-7/+91
handling changes (support [sections] to carry over to included files - this helps with backwards compatibility with existing pacman config files)
2006-05-15first stage of i18n stuff from VMiklosJudd Vinet1-2/+3
2006-03-14put back treename in db->pathAurelien Foret1-3/+3
2006-03-08all _alpm_XXX_cmp functions are now publicAurelien Foret1-0/+5
2006-03-02reworked the db object to prepare future integration with different backendsAurelien Foret1-549/+11
2006-02-22improved _alpm_list_free handlingAurelien Foret1-1/+4
2006-02-20dropped the MALLOC macroAurelien Foret1-2/+9
2006-02-20FW: spaces -> tabs cosmetic fixJudd Vinet1-12/+12
2006-02-17prepend library function names with _alpm (helped with the patch from ↵Aurelien Foret1-24/+24
VMiklos <vmiklos@frugalware.org>) added log and event callbacks to sync_commit internal transactions
2006-02-16- db_write: add support to write both local and sync entriesAurelien Foret1-40/+69
- code cleanup
2006-02-15- merged db_open and db_create into one single functionAurelien Foret1-81/+12
- moved the .lastupdate support to the frontend
2006-02-11db_write: only write non-empty fields to databaseAurelien Foret1-52/+82
2006-01-27cleaned up db_write error cases handlingAurelien Foret1-7/+15
2006-01-27fixed potential file descriptor leaksAurelien Foret1-12/+21
2006-01-09- merged pkg_new and pkg_dummy functionsAurelien Foret1-1/+1
- renamed _alpm_log_action to _alpm_logaction
2006-01-02patch from VMiklos - use PACKAGE_VERSION instead of PACMAN_VERSIONJudd Vinet1-1/+1
2005-12-26applied first try at sync conflict handling (VMiklos) plus a couple changesJudd Vinet1-0/+14
2005-10-08Code update to make use of PKG_FULLNAME_LENAurelien Foret1-2/+2
2005-10-08Reworked the cache handling to only load DEPENDS info by defaultAurelien Foret1-11/+7
2005-10-08Moved the REPLACES and FORCE package fields from DESC to DEPENDS db entryAurelien Foret1-10/+10
2005-10-06Added a missing include for CYGWIN targetAurelien Foret1-0/+3
2005-10-06Fixed an error logAurelien Foret1-1/+1
2005-08-20changed license package field to a listAurelien Foret1-4/+6
2005-05-03added some debug logsAurelien Foret1-0/+4
2005-05-02code cleanupAurelien Foret1-13/+11
2005-04-24fixed the format of %REASON% entry when writing itAurelien Foret1-1/+1
2005-04-24- fixed a cut'n'paste bug with %REASON% entryAurelien Foret1-9/+2
- factorized code between %SIZE% and %CSIZE% reading