summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/handle.h
AgeCommit message (Collapse)AuthorFilesLines
2007-03-05This commit looks much more monumental than it is. Almost all just #includeDan McGee1-1/+3
reordering and adding ones that were forgotten (noticed when trying to compile after reordering). * Updated the HACKING file to include information on #include usage. * print -> vprint in "making dir" function in pactest.
2007-02-21* Re-added a compare function for syncpkg's - it was removed without thinkingAaron Griffin1-1/+1
properly * Error when re-reading the DB for replacements, wrong info level * Removed an duplicate debug message "checking for package replacements" * Check ignorepkg for REAL upgrades... * Properly check the NOSAVE flag * some unlink_file (remove.c) cleanup * fix indent level on handle.c * Force libalpm paths to end with a '/' char * Fixed 'target' looping in conflict.c (pmsyncpkg_t, not pmpkg_t) * Added some debug output to cache and db scanning ** All pactest tests succeed again, yay **
2007-02-12* Updated the README fileAaron Griffin1-1/+0
* Removed the handle->needles param. It's not needed not that alpm_list_t is public
2007-01-24This mainly deals with code clarity- removing currently unneededAaron Griffin1-2/+2
optimizations in order to make the code much more readable and type-checkable. Every enum in the library now has it's own type that should be used instead of the generic 'unsigned char'. In addition, several #define statements dealing with constants were converted to enums. Signed-off-by: Dan McGee <dpmcgee@gmail.com>
2007-01-19Preliminary checkin for alpm_list conversionAaron Griffin1-7/+7
* renamed pmlist_t -> alpm_list_t * made alpm_list_t a public type (alpm_list.h header) * removed additional storage for registered DBs in pacman source * some code cleanup * removed duplicate (pm)list_display functions from pacman source * misc code cleanup
2006-11-20* repo-add script - to add entries to a db file directly from package data ↵Aaron Griffin1-23/+28
(no PKGBUILD) * libalpm api changes - move from a _getinfo(p, WHAT_WE_WANT) scheme to a typesafe _get_what_we_want(p) scheme [not 100% complete yet] * some const correctness changes * removal of PM_* types in alpm.h in favor of the pm*_t types used throughout libalpm
2006-10-21Minor changes:Aaron Griffin1-0/+2
* Moved the pmhandle_t extern decl around * Fixed a doxygen complaint
2006-10-20A handful of minor changes:Aaron Griffin1-6/+6
* Removed the PMList typedef, in favor of the same naming scheme other structs use 'pmlist_t' * Added a time stamp on debug output, to make it more informational * Moved alpm_db_register to _alpm_db_register, making the public function not take a callback parameter
2006-10-15Merged frugalware changes (too many to list). Also added some config fileAaron Griffin1-5/+14
handling changes (support [sections] to carry over to included files - this helps with backwards compatibility with existing pacman config files)
2006-01-02patch from VMiklos - use PACKAGE_VERSION instead of PACMAN_VERSIONJudd Vinet1-1/+1
2005-11-07fixed compilation warningsAurelien Foret1-1/+1
2005-10-10added PM_OPT_CACHEDIR library optionAurelien Foret1-0/+1
2005-10-08Merging in recent fixes/additions from 2.9.7Judd Vinet1-0/+1
2005-10-05Applied reworked patch from VMiklos (vmiklos@frugalware.org)Aurelien Foret1-0/+1
Close the lock file descriptor upon handle release
2005-04-17- general cleanupAurelien Foret1-4/+0
- added alpm_trans_sysupgrade() function - relocated some defines
2005-03-16Renamed PACXXX defines to PM_XXXAurelien Foret1-3/+3
2005-03-15Initial revisionJudd Vinet1-0/+63