summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorJack Henahan <jhenahan@me.com>2018-09-26 00:16:35 +0200
committerskullydazed <skullydazed@users.noreply.github.com>2018-09-26 00:16:35 +0200
commit2b23072c3438ea2a8a8477f738d24be2bc9aacdc (patch)
treebffde22ed40aa494ce385b62ef09f1de1cef2f09 /shell.nix
parent9dc19fdb6d0fedfb0080891a8eff49a8fc3b70c2 (diff)
downloadqmk_firmware-2b23072c3438ea2a8a8477f738d24be2bc9aacdc.tar.gz
qmk_firmware-2b23072c3438ea2a8a8477f738d24be2bc9aacdc.tar.xz
Pin avr-gcc in shell.nix pending release of 8.3.0 (#3922)
* Pin avr-gcc in shell.nix pending release of 8.3.0 There's apparently a critical bug in 8.2.0, which is now the nixpkgs default. This change overrides that default in favor of the known good version. Once 8.3.0 is the default, the override can be dropped. * Arch/Manjaro fix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 715414f96..67efb46b7 100644
--- a/shell.nix
+++ b/shell.nix
@@ -13,6 +13,13 @@ let
"-B${avrlibc}/avr/lib/avr51"
"-L${avrlibc}/avr/lib/avr51"
];
+ avrgcc = pkgs.avrgcc.overrideAttrs (oldAttrs: rec {
+ name = "avr-gcc-8.1.0";
+ src = fetchurl {
+ url = "mirror://gcc/releases/gcc-8.1.0/gcc-8.1.0.tar.xz";
+ sha256 = "0lxil8x0jjx7zbf90cy1rli650akaa6hpk8wk8s62vk2jbwnc60x";
+ };
+ });
in
stdenv.mkDerivation {