summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorRoman Volosatovs <rvolosatovs@riseup.net>2017-11-26 17:07:37 +0100
committerJack Humbert <jack.humb@gmail.com>2017-11-26 23:55:24 +0100
commit833ec84921569ce8b2351cb48dac368bd9648e35 (patch)
tree4917f2ee0a1a5549c908a4aba6a6cf1c850c8373 /shell.nix
parent53ad7375c7a6279cd289aa50b3fe7d6350f07eda (diff)
downloadqmk_firmware-833ec84921569ce8b2351cb48dac368bd9648e35.tar.gz
qmk_firmware-833ec84921569ce8b2351cb48dac368bd9648e35.tar.xz
shell.nix: add teensy loader
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 302899c52..ce17dd41e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,5 +1,5 @@
{ pkgs ? import <nixpkgs> {}
-, avr ? true, arm ? true }:
+, avr ? true, arm ? true, teensy ? true }:
with pkgs;
let
@@ -19,7 +19,8 @@ stdenv.mkDerivation {
buildInputs = [ dfu-programmer dfu-util diffutils git ]
++ lib.optional avr [ avrbinutils avrgcc avrlibc ]
- ++ lib.optional arm [ gcc-arm-embedded ];
+ ++ lib.optional arm [ gcc-arm-embedded ]
+ ++ lib.optional teensy [ teensy-loader-cli ];
CFLAGS = lib.optional avr avr_incflags;
ASFLAGS = lib.optional avr avr_incflags;