summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index ce17dd41e..715414f96 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,4 +1,5 @@
-{ pkgs ? import <nixpkgs> {}
+# dfu-programmer doesn't have darwin on it's list of supported platforms
+{ pkgs ? import <nixpkgs> { config = { allowUnsupportedSystem = true; }; }
, avr ? true, arm ? true, teensy ? true }:
with pkgs;
@@ -18,7 +19,7 @@ stdenv.mkDerivation {
name = "qmk-firmware";
buildInputs = [ dfu-programmer dfu-util diffutils git ]
- ++ lib.optional avr [ avrbinutils avrgcc avrlibc ]
+ ++ lib.optional avr [ avrbinutils avrgcc avrlibc avrdude ]
++ lib.optional arm [ gcc-arm-embedded ]
++ lib.optional teensy [ teensy-loader-cli ];