summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 715414f96..67efb46b7 100644
--- a/shell.nix
+++ b/shell.nix
@@ -13,6 +13,13 @@ let
"-B${avrlibc}/avr/lib/avr51"
"-L${avrlibc}/avr/lib/avr51"
];
+ avrgcc = pkgs.avrgcc.overrideAttrs (oldAttrs: rec {
+ name = "avr-gcc-8.1.0";
+ src = fetchurl {
+ url = "mirror://gcc/releases/gcc-8.1.0/gcc-8.1.0.tar.xz";
+ sha256 = "0lxil8x0jjx7zbf90cy1rli650akaa6hpk8wk8s62vk2jbwnc60x";
+ };
+ });
in
stdenv.mkDerivation {