summaryrefslogtreecommitdiffstats
path: root/packages/utils.py
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-03-13 17:29:05 +0100
committerDan McGee <dan@archlinux.org>2011-03-13 17:32:00 +0100
commit9730be60a8ef4a04358b0a026ce6b706de21d4e8 (patch)
tree861febdf0ee999272ce30b082752feb8c0f4f811 /packages/utils.py
parent1dc867587da6b66ca575eb26f4f65cb9d67ffdb3 (diff)
downloadarchweb-9730be60a8ef4a04358b0a026ce6b706de21d4e8.tar.gz
archweb-9730be60a8ef4a04358b0a026ce6b706de21d4e8.tar.xz
Add package epoch support
This comes with pacman 3.5, replacing the old "force" PKGBUILD option. We parse it and store it for now, but don't display it anywhere just yet. Also update a few queries relying on version differences in any of the multiple parts. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'packages/utils.py')
-rw-r--r--packages/utils.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/packages/utils.py b/packages/utils.py
index 8d9f13a..29a3087 100644
--- a/packages/utils.py
+++ b/packages/utils.py
@@ -96,6 +96,8 @@ SELECT p.id, q.id
p.pkgver != q.pkgver
OR
p.pkgrel != q.pkgrel
+ OR
+ p.epoch != q.epoch
)
"""
cursor = connection.cursor()