summaryrefslogtreecommitdiffstats
path: root/0ad/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2011-07-24 12:07:51 +0200
committerFlorian Pritz <bluewind@xssn.at>2011-07-24 12:07:51 +0200
commitb8c33ee22e78f48f52bfde7328d20efe73493149 (patch)
treeaf5a3a56a5094facb1c00472c0b1a3be7478eca2 /0ad/PKGBUILD
parent9c7f68c9ab1ed52a5c4c2cec57c71b15d2209f52 (diff)
parent34e8f8d7edc734b88753ff7cb0443f8489b02ee8 (diff)
downloadaur-packages-b8c33ee22e78f48f52bfde7328d20efe73493149.tar.gz
aur-packages-b8c33ee22e78f48f52bfde7328d20efe73493149.tar.xz
Merge branch 'master' of git://git.server-speed.net/~flo/git/aur
Diffstat (limited to '0ad/PKGBUILD')
-rw-r--r--0ad/PKGBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/0ad/PKGBUILD b/0ad/PKGBUILD
new file mode 100644
index 0000000..e2fca24
--- /dev/null
+++ b/0ad/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: t3ddy <t3ddy1988 "at" gmail {dot} com>
+# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
+
+pkgname=0ad
+pkgver=alpha_3
+_pkgver=r08832-alpha
+pkgrel=1
+pkgdesc="Cross-platform, 3D and historically-based real-time strategy game"
+arch=('i686' 'x86_64')
+url="http://wildfiregames.com/0ad"
+license=('GPL2' 'CCPL')
+depends=('binutils' 'boost' 'crypto++' 'devil' 'enet-old' 'fam' 'libogg' 'libpng' 'libvorbis' 'libxml2' 'mesa' 'nasm' 'openal' 'python' 'sdl' 'wxgtk' 'zip' 'zlib')
+makedepends=('cmake')
+conflicts=('0ad-svn' '0ad-ppa-wfg')
+provides=('0ad')
+source=("http://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz"
+ "http://releases.wildfiregames.com/$pkgname-$_pkgver-unix-data.tar.xz"
+ "${pkgname}.install"
+ "${pkgname}.sh"
+ "${pkgname}-editor.sh"
+ "${pkgname}.desktop"
+ "${pkgname}-editor.desktop"
+ "${pkgname}.png")
+md5sums=('b9df52751596633d9aab4cc3b253cb82'
+ '38abc29fc714946ed17ac86ac67fb614'
+ '92575ff82bd29369b7b0ee0ce307b39e'
+ '0a8abdb0fc32af6d48ea235c46be5b7c'
+ '1a54a2b4ab72424d14ffc42a01925ff3'
+ 'e56b164613ab929fbce76c83b766c6e9'
+ '51f83e2fd2f22764dbf775689aa155a4'
+ '51559438e79c0eb8576b98213a5d92d1')
+
+build(){
+ cd "${srcdir}/${pkgname}-${_pkgver}/build/workspaces"
+ ./update-workspaces.sh
+
+ cd ${srcdir}/${pkgname}-${_pkgver}/build/workspaces/gcc
+
+ # Official recomendations about -j parameter.
+ if [[ $CARCH = 'x86_64' ]]
+ then
+ CONFIG=Release make -j3
+ else
+ CONFIG=Release make -j2
+ fi
+}
+
+package(){
+ install -d ${pkgdir}/opt/0ad
+ cp -r ${srcdir}/${pkgname}-${_pkgver}/binaries/* ${pkgdir}/opt/0ad
+
+ # Removing useless stuff.
+ # This might change between releases:
+ rm -r ${pkgdir}/opt/0ad/system/*r
+ rm -r ${pkgdir}/opt/0ad/system/*.a
+ rm -r ${pkgdir}/opt/0ad/system/*t
+ rm -r ${pkgdir}/opt/0ad/system/*debug.so
+
+ install -D -m755 ${srcdir}/${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}
+ install -D -m755 ${srcdir}/${pkgname}-editor.sh ${pkgdir}/usr/bin/${pkgname}-editor
+
+ install -D -m 0644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m 0644 "${srcdir}/${pkgname}-editor.desktop" "${pkgdir}/usr/share/applications/${pkgname}-editor.desktop"
+ install -D -m 0644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+} \ No newline at end of file