summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-10-08 15:15:02 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-10-08 15:15:02 +0200
commit0e671b67ef77114e39fdb239a921b70df58a4730 (patch)
tree0340be250523d029c0250b47c5021ce05d112b23
parent2205ac0554474c618a642cd97f672c686d8021d0 (diff)
downloadaur-packages-0e671b67ef77114e39fdb239a921b70df58a4730.tar.gz
aur-packages-0e671b67ef77114e39fdb239a921b70df58a4730.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--highlight/PKGBUILD4
-rw-r--r--mod_wsgi/PKGBUILD19
-rw-r--r--mod_wsgi/mod_wsgi.install22
-rw-r--r--perl-ack/ChangeLog18
-rw-r--r--perl-ack/PKGBUILD29
-rw-r--r--vim-nerdtree/PKGBUILD8
-rw-r--r--vim-nerdtree/vimdoc.install2
7 files changed, 95 insertions, 7 deletions
diff --git a/highlight/PKGBUILD b/highlight/PKGBUILD
index de11471..6b921fc 100644
--- a/highlight/PKGBUILD
+++ b/highlight/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Jan Fader <jan.fader@web.de>
pkgname=highlight
-pkgver=2.11
+pkgver=2.12
pkgrel=1
pkgdesc="Highlight converts sourcecode to HTML, XHTML, RTF, LaTeX, TeX, XML and terminal escape sequences with coloured syntax highlighting. Language definitions, colour themes and indentation schemes are customizable"
url="http://www.andre-simon.de/doku/highlight/highlight.html"
@@ -8,7 +8,7 @@ license=('GPL')
arch=('i686' 'x86_64')
install=
source=(http://www.andre-simon.de/zip/$pkgname-$pkgver.tar.bz2)
-md5sums=('c0f9d4b2b5d1557f218d85929244f036')
+md5sums=('0c696d6fc3f0f1a3766b325f245f9493')
build() {
cd "$startdir/src/$pkgname-$pkgver"
diff --git a/mod_wsgi/PKGBUILD b/mod_wsgi/PKGBUILD
new file mode 100644
index 0000000..e8c4265
--- /dev/null
+++ b/mod_wsgi/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Ryan Coyner <rcoyner@gmail.com>
+pkgname=mod_wsgi
+pkgver=2.6
+pkgrel=1
+pkgdesc="Python WSGI adapter module for Apache"
+arch=('i686' 'x86_64')
+url="http://www.modwsgi.org/"
+license=('Apache')
+depends=('apache>=1.3' 'python>=2.3')
+install=$pkgname.install
+source=(http://modwsgi.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+md5sums=('c313cd7a662024866ce3376cb5a76cf6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --with-apxs=/usr/sbin/apxs --with-python=/usr/bin/python || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
diff --git a/mod_wsgi/mod_wsgi.install b/mod_wsgi/mod_wsgi.install
new file mode 100644
index 0000000..ab4d12d
--- /dev/null
+++ b/mod_wsgi/mod_wsgi.install
@@ -0,0 +1,22 @@
+post_install() {
+/bin/cat << ENDOFMESSAGE
+==>
+==>
+==> To install mod_wsgi, add the following line in
+==> /etc/httpd/conf/httpd.conf file :
+==>
+==> LoadModule wsgi_module modules/mod_wsgi.so
+==>
+==> and restart/reload Apache.
+==>
+==>
+ENDOFMESSAGE
+}
+
+post_upgrade() {
+post_install
+}
+
+op=$1
+shift
+$op $*
diff --git a/perl-ack/ChangeLog b/perl-ack/ChangeLog
new file mode 100644
index 0000000..9561365
--- /dev/null
+++ b/perl-ack/ChangeLog
@@ -0,0 +1,18 @@
+2009-09-11 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.90-1 :
+ Updated to the latest version.
+ Make as 'any' package.
+ Use build() and package() in PKGBUILD.
+
+
+2009-05-21 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.88-2 :
+ Replaced in my '# Contributor:' line by '# Maintainer:'
+
+
+2009-03-02 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.88-1 :
+ Initial release
diff --git a/perl-ack/PKGBUILD b/perl-ack/PKGBUILD
new file mode 100644
index 0000000..a01ace2
--- /dev/null
+++ b/perl-ack/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+pkgname=perl-ack
+_pkgname=ack
+pkgver=1.90
+pkgrel=1
+pkgdesc='A grep-like tool tailored to working with large trees of source'
+arch=('any')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/${_pkgname}"
+depends=('perl>=5.10.0' 'perl-file-next')
+options=(!emptydirs)
+
+source=(http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/${_pkgname}-$pkgver.tar.gz)
+md5sums=('94d2790e5e3c74561ca0cd465a494db6')
+
+build() {
+ cd $srcdir/${_pkgname}-$pkgver
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+
+ make || return 1
+}
+
+package() {
+ cd $srcdir/${_pkgname}-$pkgver
+
+ make install DESTDIR=$pkgdir || return 1
+}
diff --git a/vim-nerdtree/PKGBUILD b/vim-nerdtree/PKGBUILD
index 0e3dc57..4e87897 100644
--- a/vim-nerdtree/PKGBUILD
+++ b/vim-nerdtree/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vim-nerdtree
pkgver=3.1.1
_scriptid=10767
-pkgrel=2
+pkgrel=4
pkgdesc="A tree explorer plugin for navigating the filesystem"
arch=(i686 x86_64)
url="http://www.vim.org/scripts/script.php?script_id=1658"
@@ -16,9 +16,9 @@ md5sums=('985c217d687eceeb3146145a8bbe6cd9'
'efbd5986e691ce8c876fb86e8f5961ea')
build() {
- install -d ${pkgdir}/usr/share/vim/{doc,plugin}
- install -Dm755 ${srcdir}/doc/* ${pkgdir}/usr/share/vim/doc/ || return 1
- install -Dm755 ${srcdir}/plugin/* ${pkgdir}/usr/share/vim/plugin/ || return 1
+ install -d ${pkgdir}/usr/share/vim/vimfiles/{doc,plugin}
+ install -Dm755 ${srcdir}/doc/* ${pkgdir}/usr/share/vim/vimfiles/doc/ || return 1
+ install -Dm755 ${srcdir}/plugin/* ${pkgdir}/usr/share/vim/vimfiles/plugin/ || return 1
install -Dm755 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
}
diff --git a/vim-nerdtree/vimdoc.install b/vim-nerdtree/vimdoc.install
index 5246e5c..220693c 100644
--- a/vim-nerdtree/vimdoc.install
+++ b/vim-nerdtree/vimdoc.install
@@ -1,7 +1,7 @@
post_install() {
echo -n "Updating vim help tags..."
/usr/bin/vim --noplugins -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
echo "done."
}